You cannot connect two devices of the same type

The dimmers close to each other will only let me connect 1 of them at a time, here’s the process for how I tried connecting them:
Both dimmers have been factory reset
I double tap the reset on the first dimmer (which triggers pairing mode)
Homey finds the dimmer, starts the connection, finished with no problems and the controls are working
I double tap the reset button on the second dimmer
Homey finds the dimmer, starts the connection but then fails at the “Interviewing” stage (at which point the dimmer “status led” has gone from steady blue light to being turned off and the dimmer now has to be factory reset again for new connections). This also breaks the Homey Bridge’s zigbee connection to all my other dimmers and the only way I’ve been able to get it working again is to pull the plug to restart it.

I’ve tried this process with both of my dimmers and switched out which one I connect first so I’ve confirmed that they are both working - just not at the same time.

[Tip] Problems with Homey?

Brand? Type? Technologie? App? Version?

I have pleny of same type devices connected to one Homey so it shouldn’t be an issue. Probably something with your device.

Does exceeding the number of links cause this problem