Why turns device itself off?

I have an Aqara smart plug. I use it to turn off my floor-heating-pump at night, to save some power, and to monitor power usage.
I have a advanced flow which turns it off at 11:00 Pm and turns it on at 4:00 am. The flow works fine, but sometimes i find the pump being turned off.

Looking in the log, it seams the plug turns itself off (see attached image below).
The question is, why does it do this? Is it broken? How do i find out what the problem is?

At the moment, i have a flow which turns it on every 30 minutes, but that is nog a permanent solution.

Do you have IKEA remotes (like the shortcut or on/off buttons)? These can cause issues with Aqara devices.


Hey, thanks for your reply.

Yeah, i do have one of the on/off buttons. But i’m not sure if that is the problem, it seams to turn itself of, even if i don’t use the button.
But if the button is the problem, is there a fix?

If it’s not caused by pressing the button, it’s probably not the cause :frowning:

And besides, AFAIK it’s not possible to fix that issue on Homey if it were the case.

Shame. So ditch the remote or ditch aqara?

I’m going to try removing the battery for a while and see of that fixes the problem.

Only if that’s actually the cause. Removing the battery is a good idea :+1:t2:

I can report similar behavior. I have i.a. 6 Aqara smart plugs, and a TRÅDFRI STYRBAR remote control. When I use the STYRBAR, sometimes 1 of the Aqara smart plugs turns off. It’s random if it happens or not, and also random which smart plug turns off. It’s never more than 1 smart plug that turns off. It also overrides the “Always-on” setting of the plugs in Homey. So I’m getting a replacement for the TRÅDFRI STYRBAR.


I assume you mean a remote from another brand and not a different STYRBAR?

Yes, from another brand. I don’t know which one yet.

I’m using these now.
They work perfectly, also integrate seamless with my existing wall switches.


I just discovered that my Ikea remote turns of one of the aqara plugs.
What in the …is this?
How can this happen?

The Styrbar (in default configuration) sends commands to a fixed Zigbee group, and the Aqara switch (in default configuration) happens to listen to that same group. So at least one of the two devices has to be thrown out of that group, which unfortunately is not possible with Homey.


I managed to downgrade the plugs using this guide:

For now I didn’t notice any issues.

1 Like