Web api issues?

Are there any web api issues?

Trying to use the HomeyAPIV3Cloud command api/manager/devices/device on Homey 2023 getting a json with all device info. Reply is “homey_offline”. Have been using this command for months now.
Using the same local api command: no problems and result as expected.

The Homey web app says: Cloud status: connected. Using wifi for allmost a year without problems (not moving Homey or wifi devices). Already tried:

  • restart Homey (via app and via pulling the adapter)
  • restart modem, router and wifi
  • apps acting as expected
  • Homey browser webapp and Android app no messages or errors
  • https://status.homey.app says no problems

Seems that the web api is not working. Is there a max. number of calls each month or a max number of Mb using web api?
What can I check or test?

Did the IP maybe change? If you didn’t assign a fixed IP to your homey in your routers settings the IP can change from time to time.

EDIT: Ah sorry local works, only cloud not, have misread that part.

How are you accessing the cloud? Maybe just your token expired?

same for me for a couple of weeks

What did Athom say about it?

1 Like

I have created a new (Bearer) Token with Homey api keys (all options activated).
This is the result in Postmaster getting all devices (see yellow parts): “417 Expectations Failed”

According Homey app is the Cloud status still “connected”.
Any ideas?

Maybe that’s a misunderstanding on my part, but I thought the API keys are meant for the local api only?

I just took a look what endpoint is used by https://tools.developer.homey.app and I can access the devices with an API key and using the same url used by the dev tools:


Thanks @staeff, this is working for me.
Do you know what the diffrence is between your command and my https://<cloudid>.connect.athom.com/api/manager/devices/device ?

Has there been any changes recently in the web api calls, presuming I was using the latest web api calls.

That probably is for Athom to answer, maybe they just switched off to resolve the correct cloud server this way or they changed the URL without documenting it.

@diapolon Could you test as well the above solution? What is your exprience?
I have been experiencing this “homey_offline” behavior since this morning.

If you have either a static ip or some dyndns service and have enabled port forwarding for Homey you can also access the api via:

https://123-123-123-123.homey.homeylocal.com:4859/api/manager ( being your external ip)

i have the same problem, reboot homey don’t resolve, reboot modem also.
I use noip.com for expose local connection to internet (workaround)

Tried, it work…but it’s a temporary server? it’s not documented…

Not sure if a connected incident, but I suddenly get “Homey_offline” when I’m outside local network, but that seems only to be in the app. When I try the web version it does not seem to throw a offline error…very strange behavior. Does this mean app is using other “calls/apps” then web version?

Now we know…

The HomeyAPIV3Cloud command https://<cloudid>.connect.athom.com/api/manager/devices/device on Homey 2023 is up and running again.

yes, now it work.