Velux Integra

Hi there!

I own a Velux solar powered sunshield which I want to control using Homey. Does anyone have any experience using the Velux Active system? Or does anyone know a better alternative for this?

Velux is using the IO HomeControl standard. I saw the Somfy Tahoma and Somfy Connexoon devices, if anyone have any experience with those solutions, please let me know. :slight_smile:

If you search the forum for Velux, Integra and IO HomeControl, you get all the answers there are already.

https://community.homey.app/search?q=Velux

There is no hope for other / direct connections.
So I would suggest to look at the App

https://apps.athom.com/app/com.somfy.tahoma

Hi Dijker,

Thanks for your fast response. Thanks to the information available, I already found this app. That’s why I asked for the Somfy experience from people.

I don’t like to be forced to buy some random hardware without doing some research first. There are people who were able to fix the Velux Active using Fibaro products. Maybe others found other solutions.

I just don’t want to buy a bridge / controller with the same price as the whole Homey system, just to control one sunshield, unless I am absolutely sure there are no other options.

Sorry to jump on this thread, but I’m searching using the links above and not seeing answers (at least not in English)

I’m just about to drop a lot of money on 4 velux windows - planning the integra option, but it sounds like there isn’t a good way to link this to homey?
Or is there?

Anyone that got Velux Integra working with Homey? I’m in the process of buying a velux integra window and hope for it to work with homey :slight_smile:

1 Like

Not yet, but just had one installed.
My current plan (hope) is that the remote uses 433mhz and then to buy a broadlink to connect with homey and learn the signal

If there’s a better way then I’m ears open!!

I saw that the app posted by dijker has the Velux Integra listed, try that first.

I can confirm that Homey is unable to learn the signal. Whatever I tried, it didn’t see any signal. It seems to be a pretty save signal between the remote and the receiver.

I ended up in giving up - the Somfy Connexxoon is the best way to go. It is cheaper than the TaHoma. Big difference is that TaHoma looks more like Homey - it can connect to other services and has some sort of flows, where the Connexxoon just controls the shutters.

If everything goes as planned, I can give some feedback in October. Then a company will install extra shutters and they deliver the Connexxoon with it.

I have also a Velux Integra and there is Velux Active Gateway to control it via App, etc. I use this without a Homey integration.

Velux set up today so tried the Tahoma app posted above - you need a separate device (Tahoma) which as someone says above is like Homey itself.
So at the moment I’m at square one

Hello,

Did you ever get to try using the Connexxoon with Velux and Homey?

I did, but it’s a bit convoluted - got an extra controller then soldered a fibaro relay to it.
Stuck it in a box and stuck it under the stairs.

Works a treat :slight_smile:

Ok, good to know. That will be my last resort. My first option is to try to get it to work with Somfy Connexxoon so I am eager to know if @Mr.Nicorp got it to work.

I can confirm the Connexoon works with both Somfy and Velux, as long as both are using that IO-protocol.
You can “learn” the Connexoon to connect with the Velux products by pressing some buttons on the remote, the steps are provided in the Connexoon app and do not require much technical knowledge.

Once added to the Connexoon, you can install the TaHoma app for Homey. While adding a new device in the Homey app, you can choose to add Somfy or Velux products. Just press the right icon and you’re free to go.

Homey can now set each screen to a specific value (like 50%, or even 73% if you would like to) or just send the basic “Open” and “Close” command. These will completely open or close the screens.
I have flows which controls multiple screens at once, and they work fine too.

If you have more questions, just feel free to ask. I will check my mailbox more often to see if people respond here. :slight_smile:

1 Like

That is really nice to hear!
Of course it would be nice with native support in Homey but I have slowly given up on the one-controller-for-everything and in some cases there will be another bridge inbetween to make it work nicely.
I have a window blind order (with Somfy Conexxoon) on the way and after the summer I will get a few Velux integra devices as well.
Thanks for the happy news and maybe Ill come back with questions when I am going to install :slight_smile:

Yeah, that would have been great, but like you said: some devices still need somekind of bridge. And that’s fine with me, as long as I can use Homey to make these bridges smart or smarter.

And just once again: keep in mind that you need the IO-versions of Velux Integra. The older (RTS) ones are not going to work with the Connexoon.

Don’t hesitate to place a reaction if you need further help. And, if you like, feel free to share your flows. Maybe they can inspire me and / or other users. :slight_smile:

@Mr.Nicorp
So I got my “Exterior horizontal awning (io)” today.
Installed it and have setup the Connexoon bridge. I added my device in the mobile app and can now control it using the Somfy app.
I have also added the Tahoma app in Homey and entered my login details.
But when I try to add a device in Homey I get a message saying “no new devices found”. Did you just press install and then it found your device? Or did you have to use the remote or anything to make Homey find it?

Sounds like you are close, but just because of that, I can’t just find an error in what you did. :slight_smile:

So, you added the app for Somfy on your mobile and you are able to control the device with it. Which means the pairing part did go well.
After that, you installed the TaHoma app for Homey. If you go to the settings of the app itself (Homey app > More > Apps > Somfy TaHoma > Configurate app) does that say you’re logged in?
If so, you can add an device using the regular way, but when it asks what kind of device you want to add, you need to pick the right kind of device.
You don’t have to match the name or the icon, you have to match the kind of controls. So if your “Exterior horizontal awning” works with blinds, pick the one with blinds. :slight_smile:
Just to confirm: you don’t need the remote to pair the device with Homey, Homey will be using the Connexoon for that.

Is that working out for you?

Yes I am logged into the Somfy Tahoma app in Homey.

I think perhaps the issue is that my specific device is not supported. I wrote “Exterior horizontal awning” because that is the closest match in the list of supported devices. I have tried all the other ones with no success. I will try contacting the developer of the app but I have read in other threads that he seems to busy at the moment to add on anything.
Maybe I can try fooling the connexxon app to add it as one of the other devices :slight_smile:
They are all doing the same thing really. Open or close.

At least I got it working with google assistant (voice control) using the Connexxon/google integration but I was really hoping to get it into Homey as well.

Will try some more tomorrow-
Thanks for all the input. It really helps to understand what is possibly failing.

Well, the closest match is always good to try. But don’t try to find the closest match while looking at the name or the picture, look at the closest match for the controls.
An “open”, “close” and “stop” action will work most of the times, no matter if it is a vertical shutter or a horizontal gate. So just try another match, or just try all of them. There are not too much options. :slight_smile: