Unable to update firmware

Struggling to update FW on HP23
The device is now “stuck” in
When I try to update the app, I get the following message:
Timed out after 30000ms
When I try to update via USB tool, I get this:
Error Installing Firmware: Failed to fetch

Does anyone have any advice on how to proceed?

If it doesn’t work using WiFi OTA, and maybe tried another network?
and also doesn’t work using the USB connected to a PC


Eventually try using a short good quality USB-A to USB-C cable
Maybe contact Athom Support

Support | Homey

I did now try another network and that solved it. Do you know why my normal network would cause this?

1 Like

Spacial DNS reslovers? Pi hole? Secure firewall or something?

Nothing. Automatic updates worked until 10.0.4 and i have no changes to my network after that either

Can you open this URL in a browser?

1 Like

Yes. But the output makes no sens (to me):


That doesn’t matter. If your browser can retrieve the URL it means there’s not something in your network (or at your internet provider) that’s blocking access, so the mystery continues…

1 Like