Can't update Homey Pro (Early 2023)

Today I have recieved my Homey Pro but it came with version v10.0.0-rc.64 and the update it sees is v10.0.0-rc.110.
It cant update it as it always times out. I tried in setup proces (it just loops and retries),
i tried skipping it buy restarting Homey at update step, then going in the app general and update,
i also tried in web UI, it always times out at download step.
(1Gbps available for download)

Anyone had same issue? How could this be resolved?

Do you have any Adblock / BanIP on router?
If not, what happens if you connect it via USB and do update there?

no no Adblock or similar

have actually seen that there is USB update option but that one is also seem stuck

I had some problem making a usb backup until I tried another quality usb cable.
Perhaps if you did the same? Use another good quality fully equipped usb cable when updating by usb?


Except of the cable, I worried about the progress bar stuck actually on “installing” not “downloading”
Can you share you Browser console ? Eg. CTRL+SHIFT+I in Firefox…

Except of that, the Homey is usable after restart ?

Thanks so USB update worked after I used apple USB-C cable :pray:t2:

Thanks Henk_Renting & Sharkys :pray:t2: