Homey wont Update and Backup via USB


I need your help.
I am currently having the problem with the Homey Pro and the local backup.
I have connected the Homey to my Mac, started a local backup which never completes. During the process it just stops just before end. Tried several times even on different computers (Windows / Mac) with the same result. what can I do here?

What can I do?
Many thanks and greetings

Try another USB-C cable, there were some reports that it helps sometimes.

1 Like

unbelievable, it really helped to use the iPhone cable instead of the original!
Thank you very much, but how can this be?

So we first had “Powersupplygate”, then “Powersupply2023gate”, and now “Cablegate” too? Geez… :sweat_smile:

1 Like

Yep and we still love Homey, unbelievable, right

Getting happier and happier with my “flawless” Homey classic Pro 2019 :wink:. OK, it can have a bad temper and can be stubborn at times :crazy_face:

Otherwise it would get boring I think :upside_down_face::sweat_smile:

But your Homey Pro 2019 has troubles with updates and backups via USB as well… :wink:

Btw Athom is aware and it’s checking why HP23 backups fails sometimes with original cable.

Yeah, HP19 without option of USB backup really sucks :-))

1 Like

Well, actually you didn’t needed USB at all :stuck_out_tongue: , with https://homeybackup.web.app/login (by Geurt Dijker) I made local ota backups (human readable JSON files), worked really well. Unfortunately it didn’t work anylonger at some point, because of changes in H’s firmware… (true story)

I have no real issues with updates, sometimes an extra soft restart does the trick. About the backup via USB, true that, I used all kinds of different cables, computers, laptops, macs, but no local backup file whatsoever! :stuck_out_tongue_winking_eye: :crazy_face:

1 Like

A pity you can’t simply connect SOM i.MX6 Quad | HummingBoard CBI | Inc. WiFi/BT | 1GB RAM | 8GB eMMC - https://www.solid-run.com/wp-content/uploads/2021/08/i.MX6-Datasheet-2021-1.pdf via some socket and simply extract the data…
The SOM i.MX6 Quad is like CM4 used today in HP23 - same principle.

Btw, quite interesting to find out that our old HP19 have ethernet :wink:

True ! I used it even on HP23, still worked 2 months ago but only partially - it’s useful when you need to find old device IDs for example in the JSON.

1 Like

Yeah I’ve read about experiments by Geurt. He mentioned Athom was not going to create a driver, or release it, so it went down the drain unfortunately (or it was only intended for the new model homey, as extra or new feature).

1 Like