Can't install/update apps in Homey Pro 2023


Can’t update or install any apps to Homey Pro 2023. Trying to update one app (Heatit controls) and want to install another one (Eufy Security).
Reason I get is: “Timeout after 10000ms”.
I’m using cable for internet, not wireless. Internet is working.
Except from this all flows working and it is up to date and restarted several times.
Any idea why I’m facing this issue?
Thanks in advance!

How do you install them? By ‘Add device’ and then selecting an app?
Try the app store way of installing apps:

The Timeout isn’t necessarily meaning nothing is happening, the connection just times out, not the install process (in theory that is).

Hi Peter,

Thanks for your reply.
I’m using Homey app on Android phone (Samsung S23) and I’ve tried 1) add new device and then search on Eufy security and chosed the e.g. homebase 2 → no success 2) add apps via Homey app → no success. :frowning_face:

(Eufy Sec. app installs OK on Pro 2019, just for the record.)

I recommend you to file a ticket at Support | Homey
Don’t let the “3 week waiting time” scare you off, they do have a priority system.

The app developers can’t do much at this point I’m afraid.

Did you try to install some other random apps?

I can only ask you to do a full factory reset, create a cloud-backup prior to that, and read it back after the reset.
(A local backup won’t help, while that is a 1:1 copy of your system.)

I think this should no longer be an issue now.


I think I need to raise ticket, no possibility to add other apps as well :frowning:

These different errors I receives after pressing/trying several times.

Thanks anyway for trying to help me!

1 Like

Did you choose the right homey in the screenshot? If you have more than one homey it is a possibility that you selected the wrong one.

Hi Glenn,
I have only one, and if I press the button, I only get one option (same as displayed).
I created a ticket, so let’s see what outcome will be.


FYI, received below from support. What worked for me was to change USB-C cable between ethernet adapter to Homey Pro. Now I can download apps again. Case closed!
Hi Kim,

Thank you for reaching out to our support.

It seems like the adapter of your Homey might be faulty. I can see from the report that it keeps disconnecting and reconnecting to internet all the time, this might be related to the power supply being faulty

Could you test your Homey Pro with a different adapter, for example the adapter of your smartphone charger? Please make sure it has 5V (5.2V if using the ethernet adapter) and at least 2A (2000mA) output signal. Please do not use an adapter with less than 2A, as this might lead to loss of your data/devices.

If this does not resolve your issue, could you please another USB-C cable between the ethernet adapter and Homey Pro?

If both options do not solve your issue the issue seems to be with the ethernet adapter itself. We will then replace this ethernet adapter with a new one as well.

Please let me know if any of the above steps solved the issue!