TROUBLES with Aqara temperature-sensors

Having LOTS of issues with Aqara temp-sensors.
Because of some funny (false) read-outs I decided to test these nice little gadgets a bit more thouroughly.

Yesterday I put three of them in a row for a few minutes… the readings differed by almost 2 degrees. I know, I know… in the grand scale of the universe that is next to nothing;-) But In my living room the difference between 19 and 21 degrees means the world…

There is a temperature- offset setting to sort-off “calibrate” the sensor. Well… that is what it’s supposed to do… Actually is does nothing!! It simply doesn’t work. I tried setting it to -0.5 or +1.2 or -5 or + 10… I tried using decimal point and comma’s but it is useless… The readout stays exactly the same.

There is also something very wrong with the refresment-rate. When freshly installed, the sensor seems to work fine… It measures and returns the readings and these readings change when you put the device in a different spot. So far so good.

But after a few minutes or hours (I dunno yet) in the same position it stops refreshing and
readout will remain the same from there-on after. There’s telling how (f)actual the readout is.

I discovered this when a couple of my rooms where suspiscously constant for a couple of days.
Turned out the readout of the sensor said… 3 days ago… WTF!!

Stupid thing is that to find out how ‘old’ the readout is, you actually have to open the device (in homey that is, not physically) en click on the readout-number to find out how old it is.

as it turns out these gizmo’s kinda go into hibernation without notification…

Anyone else have problems with these sensors?

Anyone with a solution?

Anyone for a good alternative?


It’s very much a Homey issue that these sensors don’t work well, I don’t have any issues with them outside of Homey.

Thanks Robert,

Do you use a Aqara Bridge or something else?
I think I did read somewhere that you dont use a Homey at all anymore, didn’t I?

Unfortunately for me that’s no option.

I am not as Techy as you

I’m using deCONZ (for which a Homey app exists).

Google and Tweakers on deCONZ both Yell at me:
“Do not try this at home Menne, you’ll disrupt more than you can fix”

That goes me over the hat :wink:

I think it’ll be mor feasable for me to find a sensor that works with Homey
Thanks anyway @robertklep

Anyone else?

In general they work well for me. Never checked them next to each other, but it does not differ more than halve a degree from my nest thermostat for example, which I think is acceptable.

Regarding not updating, I think it has to do with the stability of your zigbee mesh. I do not have any problems with sensors not reporting or anything like that.