Trouble connecting my Aqara Hub via Matter (Merged with How are the Aqara hubs added)

I have the latest Aqara hubs, but they aren’t listed as devices in the Homey pro app. How do I add them, as they have my remotes coded… that I can’t do in Homey pro?

Not sure if this might help, but you may give it a try.
I assume you have your Aqara hubs all updated to matter… And a Homey Pro 2023

In Aqara app → select hub → general setting → expose to matter → matter pairing code
In Homey → add new device → Homey → matter → enter pairing code

This should get some or all your devices from Aqara into Homey. Dunno if they all have full functionality…

AFAIK thee is no app for the Aqara hub. I did look into it a while back but they impose too many restrictions on the API and it’s not a very good API either so I dropped it. It is sad as they produce some good products.
If you have their ZigBee devices there is a Homey app for those but that doesn’t support the hub.

Thanks for that… though homey doesn’t find the hub, despite having the QR key for it. I’ve even had the homey pro and the aqara hub m2 placed side by side, above the router, and below my phone… and it still searches then fails. What else/instead can I do?

The Aqara Hub itself will not show up as a device in Homey, just the devices installed on your Aqara Hub. Thus my reservation of “not sure if this might help”.

But strange that you did get a failed search, it should find you Aqara sensors etc… Just make sure that your Hub, Homey and Phone all are on the same network. If on IOS, restart phone after failed search. Or possible try install from web app of Homey.

However, might have misread your “remote coded”, so if its only the codes stored you want to use, this might not help at all.

@Jan_Szafranski is this your question about Aqara Hubs supporting Matter ?

Thanks again… to be honest, all I want to see on homey are the devices. I’m on android (even tried the ‘add via android’ option too…but also failed), and I’ve tried different WiFi (main router, or 2mh versions). As for codes, I’ve never used matter before, so just went to the homey add screen and followed the instructions (so can’t be 100% I haven’t missed something). I’m desperate, as the remotes I need are on there

Are all your Aqara Hubs the same? Do you have the E1 hub? If so try see if it works. It might be an issue with the M2 hub, even if its matter compatible.

And, i dont know this myself, can you move a device from one Aqara hub to another?
Other than the above, i am out of ideas, except you remove them from Aqara Hub, and add them to Homey with the Aqara app.

Nothing works. In the meantime I’ve had to do what I really didn’t want: to include alexa. It works…but in a complex way: my remotes are in the Aqara hub, alexa can see the hub but no devices, homey can see alexa…so I have had to set up a ‘scene’ in Aqara hub…scene is seen by alexa…I set up an alexa ‘routine’ to run the Aqara scene…now homey can see the alexa routine.

This is the only way I can get homey pro to ‘see’ the remotes on Aqara m2… via alexa, which I’m trying to replace with homey pro! Please homey… sort out the matter problem so that I can scrap alexa

Hello. I’m having some trouble connecting my Aqara Hub to my Homey PRO 2023 via MATTER. problems are the same no matter which method I use. ( via Homey, or via Android. ) and regardless of whether I enter the numeric code or scan the QR code. It also doesn’t matter if I do it from my PC or my smartphone. Here, the messages that appear on the screen are listed in order.
Connecting to the device,
Generating Matter login information,
Connecting the device to Homey,
The device is connected,
then I press “execute”, then …
Please wait,
Adding to Homey Pro.
and then it stops with the message,
Could not connect!!!
It should be added that all devices run on the latest and correct firmware version, all apps are also updated to the latest version. Exactly the same thing happens if I try IKEA Hub.

I have also reset my Homey PRO to factory settings, and tried both before and after I installed the latest backup.

Which Hub? And you are sure it uses Matter?

Are Hubs already supported by Homey?



Hello Morten,

Did you read the KB articles?

This caught my eye, you could try to pair it with an other smartphone maybe?

Hi Peter. I have tried with two different smartphones and, as I said, my PC. So it’s s… probably my Homey PRO it’s crazy :frowning:

Hello. as I have written;) Aqara Hub, and yes it “uses” Matter.


Hi Morten,
Do you use Homey as Thread border router?

As read in this post: Trouble connecting my Aqara Hub via Matter (Merged with How are the Aqara hubs added) the hub itself does not show up.

Which devices are connected to the hub and are they supported by Homey?


Tried adding Aqara Hub as described by Homey. Add new entity - Matter - etc. it’s pretty simple.