Tradfri stopped working?

Not sure what you mean by “flush”.

Probably, yes. The cards that will be broken will be the ones using the lamps that were removed, you should replace them with the newly added lamps.

Same issue here on 1 of my Homeys, any way to resolve it without resetting the network?
It’s not the apps that seem to cause it, since I have multiple apps for my different Zigbee devices and all of them don’t work anymore. So seems to be a Homey issue?

Number of Zigbee devices (on this Homey), is only 10, so that can’t be the issue either

I would like to invite anyone with similar issues to put in a support request with Athom.
This way they are signaled that it is more likely a ZigBee issue and not an (experimental) Tradfri issue.
I already said so, but coming from one person is not very convincing.
If no one tells them, they obviously won’t know.


Hi Robert,

Thanks for sharing the link, will see what that brings. By flush I mean resetting all Zigbee connections (if there are any) so I can start from scratch.

I will issue a support request to Athom too, as suggested by JvL.

You can perform a Zigbee reset from the Homey mobile app. That will remove all currently paired Zigbee devices from Homey so you’ll have to repair all the flows that depend on those devices.

During a Zigbee reset, Homey will look for the best (least interference) Zigbee channel to use.

Yes, I did that the first day after the issues started, since then I cannot reconnect any single lamp (by neither Ikea nor Innr apps).

I have also had this issue like so many of the rest of you. Tried what the rest of you tried and didn’t work. I would like Athom to provide us with some Xmas light and come with experimental fix for this Zigbee issue.

Hi all,

Good news, I received a procedure from Athom which solved the issue for me. Perhaps you received the same, but let me share it below. Note: read the instructions carefully before you start. I didn’t so it took me 4-5 attempts :blush:

(Source: Athom)
This procedure works best with a pc or laptop using the FIREFOX browser. Getting the full download is necessary to solve this issue. If Homey tells you it is already up to date please try to time the use of the alt button differently. If you are a Mac user, please change the alt button to the option button.

  1. Hold your Homey upside down for 1 minute to enter recovery mode.

  2. When Homey enters the recovery, please go to with a laptop or desktop.

  3. Select your preferred language, Press the ALT button to make continue in browser visible and click “continue in browser”, shown in grey.

  4. While entering your WiFi information hold your ALT button and keep holding it until you get the “Download full update” option. [Red: as soon as Homey reports verbally it is connected, follow the instruction: connect your laptop to you WiFi again!]

  5. When this process is done, please press the button “keep your data”, and let Homey finish the setup process.
    End of procedure

Good luck!

[EDIT] I had to run an update (settings menu) to get the time & date based triggers working again

1 Like

No I haven’t had this reply from Athom.

Their reply to me was: you use experimental devices, so that is likely to cause ZigBee issue across all brand/apps…

Glad it worked out for you. Hopefully it will stay fixed for you :wink:

LOL, if that’s the case, they are basically saying that Homey’s Zigbee implementation is a POS. But to me, it sounds like another BS response just to be able to close the support case.

1 Like

I did a full reset on by Zigbee network, and nothing helped. Ended up buying some hue gu10 bulbs to replace my trådfri and now all my spots are working fine (due to the hue hub ofc), but all my Xiaomi Switches and sensors are more or less useless. They don’t react half the time. So I’m contemplating just going native Homekit with as many devices I can and only use Homey for Z-wave, and have automation (albeit less powerful) in Homekit.

To me, it seems like Homey completely broke Zigbee in one of the later updates (I’ve been away from home for a couple of months, but I didn’t have these issues before I left), and tbf I’m so sick of it.

Overall I had fewer issues with Home Assistant, yes their config and everything else is more complex, but at least it always worked. Might sell the Homey Hub if the native hubs work better.

After I did the recovery procedure as described above all my lamps worked fine. I also added 3 Xiaomi sensors again, but 2 of them got disconnected again…I will contact Athom again for that.