Tado: invalid refresh token (expired)

can’t manage my thermostats anymore. I’m on Tado version 1.0.8 on Homey (early 2019)
Anyone encountered and fixed this before? I got many thermostats and many flows and like to avoid reinstallation…

This can help: logon the My tado site.
I once solved it this way.

Read it here and tried it already - to no avail. This is really stupid. Sent a message to support but it seems they’re still asleep

Have you tried to do a Repair on one of the devices as that will log in to tado again?
From the web app, right click on a tado device tile and select repair, from the phone app, long press on the device tile to open the device, then tap on the gear in the top right corner, then tap on Maintenance and then Try to Repair.


This did the trick. I wasn’t even aware of the repair feature

1 Like

I just had the same issue and could fix it by using the repair function on one device.

I am just wondering why this invalid token issue occured? Does this happen regularly?

Anyone here with more experience?

Furthermore I didn’t get any proactive notification about it. Just detected it while checking a flow manually.


Probably your API login token is time limited, and therefore it expires after X days.
It’s quite common practice I think.

I have tado myself, the expiration happens (estimated) once in 9 to 12 months.

You’ll have to request for a token check at the app developer I guess. I’m sure they “forgot” (meaning: too much work for a small customer fixable 2 time a year issue)

Unfortunately there’s more silent errors @ Homey…
Did the flow get ‘broken’? Did the tado device cards have a ! sign on them?
If so, you can use Flow Checker to detect that and you’ll have a workaround.

1 Like

Thanks @Peter_Kawa

If it happens once, twice a year than it’s something I may be able to live with. we will see :relaxed:

I will check the flow checker. Maybe this can help to be made aware of such issues. I will try.

The flow card had a red ! next to the tado action. But this is only visible when I execute the flow in test mode. Clicking on the ! showed me the message about the token. No other indication than this, showing me an issue with tado. Except when I manually turned of a tado device in homey - then this message is displayed as well. But I want to automate, not detect errors thru manual check :grin:

Again maybe the flow checker will help me.

So thanks for the hint :metal:

1 Like

In that case Flow Checker will not detect it. As I think of it, a device has to be unavailable to get a flow to the ‘broken’ status.

I have a Growatt inverter, which loses API connection quite often. The device has a ! on it, when it can’t connect, but the flows don’t get ‘broken’ status.

So, I made a flow which checks the output power of 2 points in time, every 15 minutes. Are they equal? > restart app.
You could do something similar with the room temperature. Is it exactly equal, now and X hours ago, it probably doesn’t work anymore.

Will think about your advice. Still new to homey, so I guess I am still in the learn modus. While I already integrated different devices and implemented various flows I gained some experience. But I guess I am still a newbie. So still long way to go…

Thanks for your quick help. I appreciate the very active community here.

1 Like

Ah I see. Homey is very addictive, be warned.
I made a flow for tado I didn’t have yet :wink:
The app used is Device Capabilities

This is the [number] variables, which hold the room temperature in this case, provided by the two Device capabilities flowcards:

If it doesn’t make sense, just ask :wink:

In fact I tried the app Device capabilities two days ago for something different. But I failed - still need time to work on simpler things. For example the configuration of Device Capabilities looks like magic to me. Simple but complex. I am not a skilled programmer, but I do have some experience on process management. As long as a flow is simple and I understand what I do with flows, actions, variables etc I do feel comfortable. Trying Device Capabilities didn’t immediately work out. I tried for couple of hours. With no success in getting just a simple device up, I stepped out for now :woozy_face:

I understand, you can create very customizable virtual devices with it. But it’s a bit intimidating for new Homey users.

But the flowcards used, are just “Then” cards which come with the app. No adding of devices needed.

1 Like