Unauthorized Tado thermostat and thermostatic

When adding Tado thermostat and thermostatic they are unconnected in one day. The error is: Device has been unauthorized. Please add the device again.

I tried it three times, every time i have to fix the flows within the devices.

Who has the same problem or a solution?

Homey firmware 1.5.12
Tado V2.0.1

I noticed the same issue here. No solution as of yet.

Me too. Wrote to Athom-Support. Waiting > Think they will find a Solution.

Request is #8235, Homey 1.5.13-RC11, Tado 2.0.1

1 Like

Same here.

I have notified the developer about this, he will try to fix it asap! Thanks for reporting it.


Same here last weekend, not the first time this happened unfortunately.
I was only able to relink through the Homey app, browser progress wheel kept running indefinetely.
All these annoying things just dim my initial Homey enthusiasm.

The issue seems to be known since August 3rd: https://github.com/athombv/com.tado/issues/16
@Bram Is there any news about when this issue might be fixed? Since my presence detection works pretty much based on Tado, all the automations that work with this currently fail to execute properly. The WAF of Homey is dropping every day now.

Hope the issue is fixed before the temperature is getting lower! :snowflake:

I also have the same problem since the 2.0.1 update. Is there anyway to roll back to version 2.0.0 as that worked fine?

1 Like

Same issue here.Hope they fix this before winter.

@Bram the issue with the tado app isn‘t fixend since a couple of weeks. Why?

Now the heating time is coming and now it would be really useful.

Let me check it with the developer what the status is

thank you @Bram

@OpenMind_NL, Can you shed a light on these problems?

1 Like


A few weeks ago I noticed that the connection between Homey and a number of tado devices was broken. If I remember correctly this was after a Homey update (experimental) but it could also have been an update of the tado app.

I think I solved it by removing all tado devices and adding them again, but I do not know for sure. In any case, the tado app has been running here for a while without any problems. tado v2.0.1 on Homey 1.5.13-rc.11 (experimental).

About the development of the app. I stopped after version 2.0.0 was completed. Further development is now in the hands of Athom.

Removing and re-adding the tado devices is only a temporary fix. The problem comes back as soon as there is a single issue with contacting a device, e.g. internet disconnects or even a simple timeout. A single failure to connect permanently marks the device as unauthorized and then no further attempts to connect are made.

Is there any way to roll back until the problem is fixed?

Right: remove and readd the devices only Works for one or two days. Then the chains are seen as the device icon.

When @OpenMind_NL was the Developer of the app you could be save that the issues were fixed. But from the Point of Athom develope the app nothing is made. @Bram do you have an answer from your Developer now? It is a heating app! One of the Most important apps now. Music apps etc. can really wait but a heating app which is Broken really sucks!!

I will do some QA testing this week with the Tado app to see if I can reproduce this bug. Please report the issues you have via the “report an issue” button in the Appstore. Try to give a clear explanation what the exact issue is. This way I can forward it to the developers so they can try to fix it asap.

@Bram the bug is reported on 9 july and 2 aug

And here a new one:

So when can we expect that someone at athom will take a Look?