Tado thermostat and radiators give white screen after opening in Homey app

Hi all,

My Tado thermostat and radiators are still visible in Homey app, but after clicking I get a white screen and the app crashes. My Homey, the app and the Tado app are on last version.

Any other having same bug?

Rebooted Homey and rebooted the Tado app, without luck.


Yep here too, reported it also. Maybe you can that Also. That wat they know it is not just me.

You may try deleting and re-installing the Athom-app on your phone. Might help…

Also reported it to Athom

Just got a message that they are working on it

Please install the newest beta (3.0.3) of the Tado app to resolve this issue :slight_smile: (https://apps.athom.com/app/com.tado)


Same here…thought it was just me again
Never a boring day in Guinea pig land :partying_face:

Edit: interesting find: Insights seems to still track the temperature changes whilst the app only produces the white screen

1 Like

This indeed also worked for me, thanks

I have installed the beta yesterday because I had the same problems. Until now no problems.

Warm water does not function. When you lower it from 55 celsius towards 40 celsius you can’t go back

Same here with FIBARO thermostats. Running the latest version of the Figaro app.
Anybody the same problem and fix ?

I guess everybody in this thread has Tado and not Fibaro. We have updated to a beta version of the Tado app and this solved it.

@Bart No, the app still doesn’t work (tried the Beta). When adding Tado devices, the app asks to authorize. After authorizing, I get the message ‘You can now close this window’. When closing the window, you go back to the app and there is a blank screen which stays there forever. Devices are not added/authorized.

Hi Paul, sorry to hear this. It worked for me and quite some others I have heard. The blank screen only appeared when opening a Tado device from the Devices menu.
I think you should open a support ticket at Athom directly.

I’m still on the Beta version of Tado and latest version of Homey and Homey app (iOS).

ok, different ‘white screen of death’ problem then :slight_smile: I already submitted it to Athom, but no adequate support as usual.

Better change the title of this topic to : Fibaro and Tado thermostats…

After I reported to Athom, nice E-mail back that there are more reports like this and they are working on it.

Yesterday, update Homey 2.0.5, I say to myself “Yes this is it”, :-1::-1::anguished::slightly_frowning_face::frowning_face: Too bad no change.