Cannot get any TADO deviices added to Homey Pro

Hi all
I’ m new here, unboxed my Homey Pro 23 yesterday.
Downloaded both available TADO apps (but no success with either of these)
I first tried to find my v3+thermostat. (Had put tado bridge in the pairing mode)
It then directs to the TADO site ( where I click ok (credentials shown) and it then tells me to close window
Back in Homey app get white screen, telling me to log in to the manufacturers website (which I just did for authentication??)
Then after a while I get an error message

Any ideas what is causing this and how to resolve?

you tried it with different browsers or with webapp or different device? Nothing in your network which could cause is (firewalls or something)?

I never had to put the bridge in pairing mode.
Your Homey connects to the tado cloud directly, not to the bridge…

Firewalls like Hielke mentioned, temporary disable any network influencing device/service (adguard, pihole and such)

Is your tado phone app still able to operate the actual thermostat?

If yes, follow this link
and logon.

When it succeeds, everything on authentication level seems to work.

The Homey to tado cloud logon process pretty is pretty straightforward.
It won’t work with the tado bridge in pairing mode.


While things often go wrong when you leave that Homey screen to find or copy your credentials →
Have the user & password available @ clipboard or in your head, so you can enter or paste them without leaving that screen

Thanks for your suggestions

Have tried it on multiple devices: iPhone, iPad, windows laptop, all same error messages.

The Tado system still responds to iPhone etc, tried the link no difference.

Read at other discussions to switch off the 5Mhz WiFi, no difference either

Same with firewalls and other kinds of security stuff I’m aware of on my system.

Had the Tado bridge in pair as well as not pair, but neither found the devices.

After having set all my network settings back to normal, Ithen “added” the “free” Homey which allows limited number of devices to be connected, via “my Homeys”.

First thing I did was add the device Tado thermostat

And this worked smooth !!

(as smooth as I would have expected it to go on the Homey Pro).

It connected to the Tado-authenticate site and when returning to the Homey app, it was there AND works (at least I can change set temperature etc via the Homey app)

So why does it work in the free Homey, but not with the (not free) Homey Pro?

Would it be possible to move/migrate the connected Tado thermostat from the “free Homey” to the Homey Pro, and if so: how?

Yeah, that’s the big question.
The free Homey a.k.a. Homey Cloud or -Bridge is a cloud device, Homey Pro is a local network attached device, so I still can only think of a network disruption.

What just occured to me: Maybe your internet connection is connected through CGNAT. Inform with your internet provider if that’s true, and request removal of CGNAT from your connection (they have to honour that request).
(With CGNAT you share your public IP address with others, so probably the tado authentication process can’t find your Homey Pro, and the request times out because of that)

No, nothing is interchangeable/migratable between Homey cloud and Homey Pro