* Solved * Tado Smart Radiator Thermostat stopped working after firmware update

Hi! After i upgraded my Homey Pro (Early 2019) to firmware 10.0.6, it can no longer control my Tado Smart Radiator Thermostat. Everything else is working, it shows set temperature, measured temperature and humidity, but trying to change set temperature manually or through a flow fails. I get error message “Invalid Refresh Token” followed by a long string of letters when trying to manually change set temperature. I can change set temperature in the Tado app on my phone without problem.

I upgraded the firmware the 8th of february, 17:12, and after this I can see from the temperature history that my temperature control failed. At the same time, I also downloaded the test version of Aqara app, and installed a T1 temperature sensor. I’m guessing this does not affect Tado, and that the firmware upgrade is the reason.

Attempted solutions:
Restart Tado App
Restart Homey

I am hesitant to reinstall the app as I assume this might mess with my flows?

Any ideas on how to solve this? I have sent a diagnostic report to Homey, but before i realized that the issue coincided with the firmware update.

  • SOLVED *

Homey customer service adviced me to long press the device in the homey app → Settings → Maintenance → “Try to repair”

This prompted a log-in to my Tado account, and now the device is functioning again.