Shelly 1L - Add Device => select icon freeze

Dear all,

Today I want to add my 1st shelly device.
It’s working fine until the point I have to select an icon.

If I select ‘use default’ I get an empty screen with ‘Select icon’ title and nothing more happens.
If I select a svg icon I also get an empty screen with ‘Select icon’ title and nothing more happens.

The device is working fine via the integrated web interface. So I think no device problem.
I’ve tried iOS and

Does someone has an idea how this can be solved?

1 Like

Solved by fw update.

I am having the same problem with recent firmware…

1 Like

Same issue here while trying to add Plug S

1 Like

Make sure you enable cloud before checking for newer firmware versions.

1 Like

Same Problem here: Shelly1, working well in the shelly App & Cloud, Firmware is up to date, but when I try to connect it with homey, i get the freeze after the Icon-Selection.


Actually had to update my “Shelly Plug S” once I added it (and in the cloud) today (5th dec 2021) - but still could not get past the “Select icon” - screen in Homey. So the problem is not just in Shelly 1L. :thinking:

I now have three new “Shelly Plug S” for the X-mas lighting that I bought to include in Homey flows… but stuck at this point. :weary:

What firmware version? I just tested a Shelly Plug S with firmware version 20211109-130223/v1.11.7-g682a0db and added it without any issues.

Turned out that I had an old version of the Shelly-app which showed wanting an update after a restart of my control-unit. After that - it flagged that the units needed further update (which it did not do before).

So, finally - with new firmware - just as you pointed out - it worked! :smiley:

Thank you for pushing me to check them all!

Same problem here… trying to add Shelly button 1. Static IP, working fine in Shelly app, but in Homey stuck on select icon. When I use default it freezes. Shelly button firmware is up to date.

Why don’t people just follow the installation instructions.

1 Like

Same issue here… For the last year, everything was working fine, until yesterday Homey and Shelly App updated. Since then my flows don’t work anymore, the Shelly devices are still displayed in Homey App but switching them does nothing… when I tried to delete the devices and readd them, I get stuck on the “Select Icon” screen. OF COURSE I checked the firmware and followed the instructions on how to add Shelly devices to Homey - I am using about 100 different Shellies in my Home which control lighting, heating and other stuff.

Please, can anyone help me? Since I have automated most of my home with Shellies, this problem really hits me hard!

Have you tried the suggestions in this post?

No you have not followed the instructions. This issue only occurs when people do not follow the pairing instructions from the support topic by the letter. You have skipped step 2. Your firmware is still outdated. You need to first connect it to the cloud and then check for a new firmware version.

All my devices are connected to the cloud by standart, and have ever been. Saved my wife yesterday when the heating wouldn’t turn on and I did it from my office by phone…

I’ll set the whole system up again - still it is very annoying that with a simple update suddenly my whole smart home working fine for over a year was disabled.

That’s probably unrelated to not being able to pair devices. You should follow the troubleshooting guide from the support topic (which includes the suggestion @robertklep already did). Not being able to control devices is related to network configuration / stability , either in your own network or the network stack of Homey. Both are our of my hands as app developer.

Ok, thx anyway, I’ll try replacing the power supply next, and eventually transfer my flows to scenes in the shelly sphere…