Shelly device disconnected

I have several Shelly devices in my Homey configuration. One of them has been disconnected. The disconnected device pops up as a new device with its old IP-address. I have tried to add the device again witout success. I receive a time out message after pressning ’use default icon’. I have factory reset the device, changed the IP-address, restarted the Shelly app, restarted the Homey etc.
The device has a static IP-address.
Is there someone with similar problem and maybee a solution?

I think I had a similar issue on two of my Shelly devices a few days ago. I was able to solve it by doing the following:

  • Cut the power on groups with the impacted shelly devices (mine were Shelly Switch 1 and Dimmer, so I could not reach them to power cycle them)
  • Turn off my router and internet modem
  • Wait a minute
  • Turn on network devices
  • Turn on the power on the power groups with the impacted Shelly devices

After this everything was fine again.

By the way, I do not have static IP-addresses.

Thanks! I will try that combination later today.

You need to update the firmware of the device as well. If it tells you it’s up to date connect it to the cloud and check again. The time out during pairing is caused by an outdated firmware.

Thank you very much! The cloud connection and firmeware update solved the issue!

When you update the firmware does it change also the settings of the Shelly?

No. The settings is still there.

1 Like