Can you explain how i can make a virtual device activate by me being precent in Homekit? Or am i not understanding what you said?

Sorry I must have missed your post.

Sure so I created a virtual device that is exposed to homekit. In homekit I have created a routine where ’ if the last one leaves the house then turn off device X ( in this case the virtual one ) .

In homey I have flows with an AND condition with the virtual device.

We leave the house, homekit turns off the virtual device. In homey a flow is triggered : If virtual device is off then turn off all lights, set temperatures everywhere to 18 degrees

Ah now i see. I need a homepod, apple tv or a dedicated ipad for that to be possible.
Thanks for your information.

The guide is incorrect, but it did point me in A direction. I already had all battery optimizations anc cache clearing options turned off for Homey and Owntracks, but I found a way to ’ lock’ apps and so far so good.

p.s. in regards to my GPS reception, in my house I have fix, but at work I don’t.

You could try to navigate from home to work and not closing the phone (display on) until it has a wifi connecting from work… (that did work you said, navigating with your phone in your car)
So then Android could connect those two facts with each other. I’m not a Android guru, but this would be the theory of high accuracy location modus in Android.

But still, that is a drawback of gps based solutions, initially indoors they don’t work it needs something extra. Over time it will get it.

I have following flows created:

when homey detects my presence set Boolean “person X home” to yes
i use IFTTT on my phone to start a flow when my phone connect to home WIFI. The flow will set Boolean “person X home” to yes
I use IFTT presence on my phone if I enter an area set bolean “person X home” to yes

I have a flow which goes: if Boolean person X is set to yes, and Boolean Y is no then switch on light.

I use the IFTT presence when exit area start flow to set Boolean "person X home: to no.

The last has sometimes a delay, but is working quite good. With the first i trust on WIFI as best, but if my WIFI on my phone is off, i still have the presence of IFTTT and Homey. So three backups.
Until now it is working great. Only needed to created quite some flow if you have 2 people.

A week ago I updated my Galaxy S8 to Android 9. Since then the presence detection doesn’t work anymore. Not even sporadically.
Before that it worked really well with the new Homey and Homey app version. I was glad not to have to make the detour via Tasker and webhooks anymore, which was not so reliable.
Since it worked flawlessly in Android 8 I think it is a problem with Android 9. I’ve also already turned off all the battery savers.

My Android 9 phone also never works. My old Android 6 phone worked flawless. I’ll check my wife’s phone too, see if that’s pre-Android 9

I’ve used Tasker with Homey for presence and it worked great but after the upgrade to Homey 2.0 it stopped working. Any suggestions on how to get it to work again? or may I ask you to explain how you got it to work?

The flow is the same in Homey2.0 as before I upgraded and the Profile in Tasker is the same. It seems my HomeyID is the same. Just don’t understand why it doesn’t work anymore.

I follwed the instructions in glijie post (the second post) in the old form found here

I heavily rely on a working presence since I use it to turn off a heater.

I don’t know if your able in Dutch, or if it translates well via google translate:

I’m happy with Homey yet running on V2.0.5.
Only 2 items I do realy missing:
A backup system and a good operating geo fencing/ présence system

Well, regarding geofencing, the athom homey app geofencing. I don’t think that they will get a good working geofencing ever.
It is difficult work to get it just right you know, don’t get me wrong, and it is tedious to maintain. I’m not suggesting that it is easy.

They are working on it for a few years now and there was never a moment in time that it all (iphone/android/different brands etc) worked like it should. (like in use it without any worry)
They did actually some updates over time and then some improvements were there. But the development is so slow that while you are waiting for a fix for an issue you have filed, my wife buys yet another phone on witch that homey geofencing app does not work. And then you wait for a fix for the next issue.

I’m sorry to be the guy that says it out loud. But just not wait for it to ever happen. Move on to other apps (homey apps, or iphone/android apps) that do work and give reliable geofencing.
And life happily ever after.

Thank you for the help, took a while for me to figure out how to set a webhook in a flow by selecting logic from within the flow, I previously used HTTP request flow cards for this but it seems that does not work any longer. OMW to test it now.

Hi all, I’m quite fresh with Homey and I installed IFTTT for geofencing because I didn’t even know geofencing is a feature of Homey.
I think you always should accept a bigger radius than tight around your home (I took my complete village), and some delay in time to get the right status.
I’ve set my flows in this way that it’s not critical, for example I do not expect that the gardenlights turn on when I’m driving into my street.
So in this way it’s works pretty ok. Other toughts?

I personally think it depends on what you wanna control w/ the presence variable.
The garden lights getting switched on when driving into the street sounds nice … :grin: