Homey Community Forum

Plant id and inverter name Solarman for the solar panel app

I’ve got solarpanels and i installed the Solar Panels app.

I’ve got the app Solarman on my mobile. I see all kind of numbers and ‘id’s’. Is someone using the same combination and can tell the right place for the plant ID and inverter name?

I have the same problem, i don’t know where i can find the site ID from the Solarman. Can someone tel me where i can find the site/plant ID?

I have installed the latest version of solarpanels, but can’t find the trannergy panels anymore. Will trannergy be back in a later version?

After days of searching finally found the id! Just login to SolarMAN website, on the homepage look in the adres bar : http://www.solarmanpv.com/portal/Terminal/TerminalMain.aspx?pid=12345

Use the digit behind ?pid=

Solved. :smiley:

1 Like

1,5 year after you’r answer you helped me out… thanks

hello
i tried to connect to the SolarmanPV site…found the ID but now get an;
Error: Could not find that PairSession

logging in with those credentials in the website works so those credentials are ok

any thoughts?

a few minutes later…

After a re-install of the app through the homey website it worked…

I just got my Solarman installed today. I’m not getting what I have to do. The guy who installed it has provided me with a username / password combination registered on my email adres. I can log onto the app on my iphone with this password. I can see everything, but the plantID I cannot find.

According to the above statements, I can find it on the website but I cannot login to the website with these credentials. Thus I have created a new account. It doesn’t show any data but it does show the plantID in the URL. In Homey however it asks for a username, not an e-mail address, and indeed, I cannot log on. It tells me it cannot find the pair session.

With the username / password combination I received from the guy installing and using a plant ID I saw on a screenshot hes send I get a error message saying “You have been logged out or you have no authorization to use the service”. I’m registered as ‘owner’, so the latter seems far fetched.

I’ll try again if the device is online, if anyone else has some nice ideas, please feel free to spam :slight_smile:

That happens when you switch between the Homey app and another app on your phone. Copy the required information first, then open the Homey app and paste it there. You may kill the Homey app first, or log out and back in again.

1 Like

Yes, you are right, unfortunately it times out after 3000ms when searching for devices. Will try again tomorrow when the inverter is online again.


Right, did have to do with the device being offline, now I could add it. Thanks

Waar vinden jullie nu het ID dan? Kan het echt nergens vinden.

You don’t. The backend has changed, app doesn’t work anymore. No solution yet.

Is there any way to find the/an API? I converted from Trannergy app to Solarman app, but my API (which I created at pvoutput.org) is not working anymore.

I created the following issue. Solarman doesn't report production anymore · Issue #166 · DiedB/Homey-SolarPanels · GitHub

Unfortunately they aren’t responding.