Pairing Ikea tradfri problems

Hi all. I bought 14 Ikea dimmable GU10 bulbs and started pairing. With some problems I paired 5 (some started immediately and some required reset by 5 times quick on off). When I got 6th I could not pair. I tried 3 next ones and none of them I could pair. Went for reset of Ikea app, restart Homey and PTP for 30min. Nothing helped. I read some forum regarding hard limit of zigbee devices = 20 but when I counted all my devices I was already above it. Then I tried some crazy hack I remembered from pairing of Hue bulbs. I took Hue dimmer put it directly on Ikea bulb. Pairing on Homey for GU10 bulb was running. I pressed little line button on Hue dimmer and waited. After 4secounds bulb reacted and dimmed to 50perc. I took dimmer out from bulb. After 3 secounds pairing on Homey started with no problems. After this I did same for all remaining bulbs and all were paired immediately with help of Hue dimmer. Homey was apx 1m off bulb all the time.
It seems to me like Hue dimmer is able to force any Zigbee device to strong pairing mode by pressing and holding small line button. If anybody is able to check it on other devices (of zigbee I only have lot of Hue and Ikea lights) and verify it would be nice.

Did you switch off the already paired bulbs before adding the next? It’s recommended by Ikea and known to give problems.

I only bought single ikea bulbs - no gateway. ( so theoretically they should had been unpaired when bought). Still I had lot of problems with pairing and I only managed first 5 pieces ( with difficulties). After that I could not pair any next. Above hack meant that I was able to pair others on first try with no problems at all.
EDIT: only now I understood what you meant. I did turn off all sucesfully paired bulbs before unscrewing

When experiencing problems when adding IKEA devices, this is what worked for me:
0. Keep the device close (<20cm) to Homey

  1. Make sure the device is ON
  2. Add device in Homey
  3. When screen “add device” appears, turn OFF (2sec), ON (0,5sec), OFF (2sec), ON (0,5sec), OFF (2sec), ON (0,5sec), OFF (2sec), ON (0,5sec), OFF (2sec), ON (0,5sec), OFF (2sec), ON
  4. After some 4sec, the device will blink once.
  5. The pairing will start.

I hope this helps.


Anyone have any luck pairing a Floalt panel? I am unsure how to proceed… I guess I have to pair the Trådfri remote first, and the use it to toggle the panel on an off somehow to be able to get it into pairing mode?

I think you need to power-cycle the panel 6 times to enable pairing mode. I believe that when it is in pairing mode, you should be able to see a blinking light on the panel side somewhere (see the manual).

1 Like

Remote is not needed. Just power cycle 6 times close to the Homey.

I had to open the second Floalt panel to pair it (since I have two on same manual switch), and manually switch it on/off 6 times with the cable going into the LED driver. While in pairing mode homey was far away, but used another node in the network or something. That worked for me.

Just a heads up: in 5.0.0 Zigbee pairing seems to be much more reliable. Also, the Test version of the IKEA app is much improved.

I had the same problem, it was not possible to pair any Ikea device with Homey Pro. I got it solved by performing the following steps:

  1. Removed all existing zigbee devices from Homey (and yes, I lost all the history for those devices)
  2. From the Zigbee menu in Homey I “Reset network” (I noticed that it changed the channel from 11 to 14)
  3. When trying to add an Ikea bulb it worked! I had to use the 6x on/off procedure for all of them. I continued to add other devices, some of them I had to perform the add procedure twice, but all of them worked.