Netatmo doorbell doesn’t trigger flow

Hi there. Since 2 weeks I have the Netatmo doorbell installed. Of course I connected it to Homey. I created a simple flow that plays a sound over my Sonos speakers. The flow worked perfectly when the doorbell is rang. However, since a couple of days the flow doesn’t respond when the bell is rang. The flow works fine (logically) when I just test it.

What changed. Homey installed their latest update. I had to disconnect the doorbell and reconnected it. I have the latest versions of the apps. I tried to repair the connection. What could be the issue here.

That means the flow isn’t triggered by the Netatmo app (testing a flow skips the trigger and executes just the AND/OR and THEN parts of a flow). Since the app is developed by Athom, you can try and send a support e-mail to

Thanks Robert! Much appreciated!!

My issue proofed to be a bug. Athom send an updated app for Netatmo some days later. Everything works fine again!!

I have exact the same problem. Tried everything.

  • Restarted Homey
  • Restarted Netatmo app
  • Removed/Installed Netatmo doorbell device in “Homey devices”
  • Started “repair” of the Netatmo doorbell (approve API Access)
  • Made different flows to start different devices
  • Last effort I will undertake is to reset the Netatmo doorbell and see if things start working again
  • After not touching anything and within 12 hours everything started working automagically! I did not reset the doorbell. I am happy everything now works as expected but confused as what could have triggered the repair :slight_smile: