Netatmo doorbell doesn’t trigger flows anymore


I recently bought a Homey Pro early 2019. One of my first flows was starting a dingdong-sound when my Netatmo doorbell was pushed. This worked fine for some weeks. Than it stopped working. I can still start the flow manually, but de doorbell doesn’t trigger the flow. I tried:

  • removing and re-installing the doorbell in Homey
  • removing and re-installing the Netatmo-app in Homey (both versions)
  • resetting the doorbell
    -removing and re-installing the Netatmo app
  • making a new Netatmo account and installing the doorbell on Homey via that account
  • cleaning up Homekit and reinstalling the doorbell in Homekit
  • contacting the app-developper. He was very helpfull but the last option was to take over my Homey (which didn’t sound as a very save option).

Any suggestions or people having the same option?

Oh wow. It’s good practice to keep an eye on security, but when an app developer offers to help you out, but needs a temporary (full) access to your Homey, why would you doubt the person’s good intentions?
This developer offers SERVICE, probably at no charge.
I haven’t read about any cases a dev would offer this service to anyone…
I think developers rarely take the time and effort to help you at that level.

Just a thought. :man_shrugging:

1 Like

Hi Peter, I agree with you that this is excellent service of the app-developer and I appreciate his efforts. Still, giving acces to my Homey to somebody I don’t know is my last option. Any suggestions what could be de cause of my problems or my next action (besides giving acces…)

And because I did something similar (invited as Guest to get Doorbell and Netatmo Welcome integrated), I remember very well that given developer “warned” me several times about privacy concerns, which I was fully aware but I assume he did the same in your case. Just what I mean is that he really cares. …but yep, it’s still a risk.

It’s btw not take over - you are inviting him to the Household and giving manager access, but you are still owner.

So I guess what is not working is BitCino integration, right ? You can setup temporarily Athom Netatmo integration, which I guess you did - and even you setup new flow, it was not triggered ? .

Anyway, my experience recently, I enabled Google “Dong” - Voice notifications in the Home app - I don’t know how Google did it but the “dong” and voice - Someone at the doorstep ? is immediate.

Yet, the Homey flows I have linked to that, last 1 or 2 weeks get triggered with minutes of delay, which I think it’s somehow linked with Netatmo API, not really with the Homey integration as such. I was currently not looking on solutions nor contacting developer because it has changed without any latest release of BitCino integration.

Well, in the end, after alternately installing the Athom and the BitCino app, I installed both the Athom and the BitCino app and made the same flow (playing the dingdong-sound) for both. And…. somehow it works now. After that I removed the flow with the BitCino app and it is still working.

Have you send diag. report to the developer, right ?
In my experience, Athom integration has been very unreliable for past two years, had multiple contacts with Athom but it didn’t improve - so .

I did report to de developer that it somehow started to work again. Thanked him again for his help and advise. Did’t send a new log-file and he didn’t ask Chances are it was a temporary bug. I will never know… For me: case closed.

hi, any idea, how did it work again? i’ve got the same problem. i’ve been using doorbell for a year without any issues. suddenly it stopped triggering flows. i did anything what i could think about, installed again netatmo app, installed as well an unofficial app bticino/legrand/netatmo, did new flows, restarted everything. and nothing. anyone an idea?

It still works for me…have you tried to reboot your doorbell and then test it again?

to be honest i didnt reboot the doorbell. but suddenly today, after a month of silence it started to work, by it self. have no idea how and why, couse i didnt do with it anything by the night time. i’m afraid now to touch any flows, not to get it broken again.

i wonder could be the cause of if. i’ve got lots of netatmo stuff in my smart environment used for years and never any problems with it

I had the trigger function broken and fixed several times. When it worked, it worked after installing both apps (Netatmo and Bticimo) and installing two doorbells (and tinkering a lot). When it worked on one doorbell and I tried to clean up (removing the doorbell that was not used in a flow, and the corresponding app), it stopped working and I could start all over again.

What worked for me last time it stopped working: go to the Netatmo Security App, settings, your home, your room, your doorbell, press three dots in upper right corner, restart device.

This Topic is closed, because all problems seems to be solved.
I also wrote to ask for help in the App Topics (Welcome to the forum! Rule no. 13), which wasn’t done.

So please in future ask in the appropriate topic as linked in the App store or use the search to centralize questions about a specific App or device/brand to keep the forum clean as possible.