Netatmo Doorbell is this working or not with Homey (pro), got some mixed searching results

Is this doorbell (Netatmo Doorbell) currently working with homey or not?
When i search for info i get different info back.

What is must do in Homey is:

  • when someone rings the doorbell, i should be able to start a flow, this ‘instant’, without any major delays.
  • i must be able to use/take a snapshot of the camera picture and use i in flows (snapshot tag card)

What is also should be able to do, but outside Homey:

  • record on local Synology NAS, i checked that and that should be possible…
  • receiving push message on phone when someone presses doorbell, it would be surprised if that was not possible, haha, but it should be without major delays.
  • answer/reply doorbell when not at home, also here i would be very surprised if that would not be possible, haha

Who has such a device and can confirm the Homey part of it is still working? (i read somewhere that is was broken and could not be fixed…)

Maybe contacting the app creator is an idea?

In your case Athom is the App creator, the link to Athom support is present on the app page

not really, athom reply is very slow and one sided.
looking more for user experience advise

Weird, I always get a human response @ the same day, or @ the next working day. Pretty fast for an unpaid service.

Hi @B3rt ,

I have one of these and I can do:

  • start flow (within 1-2 seconds) - this latency I cannot explain - I have lots of flows that trigger things that take a little while. I do have a lot of devices though - please Homey make a more powerful device - it is not ZWave or Zigbee related.
  • I use the snapshot functionality to display a notification - only it makes 2 notifications, one with “noise” and one with the actual picture. This looks like an issue with the app.

Then outside Homey:

  • the device does not have a stream URL so I could not get it to work on Synology Surceillance station, unlike the Outdoor cam where this works flawlessly. The doorbell DOES have a dropbox link which I sync to my synology again everytime it detects something interesting. The person detection is not flawless. Sometimes a person is not recorgnized and I miss events. Still 90% of the time I get a short clip of someone standing at my door
  • the push message outside homey is delivered by the netatmo security app itself - this works perfectly.
  • answering the doorbell, so speaking is also possible via the native netatmo app

Everything worked fine until 2-3 days ago when my doorbell lost connectivity to my LAN and I cannot get it restored. I think this is coincidence. I suspect a hardware issue and have raised a ticket with Netatmo. Homey, Google Nest hub and the Netatmo app cannot connect to the doorbell at present. They CAN connect to my outdoor cam and that part still works as expected.

Hope this helps.


Meanwhile i received my netmato doorbell and had some problems.

  • the fuse blowed eachtime i pressed the button
    I contacted the seller and they send a new doorbell, this one i received today and i installed it, this time no fuses where blown.

I got it working as stand-alone, then i added it to Homey, this went rather easy.
I already had a smart doorbell, so i only had to change the flows to get the netatmo to blend in.

Everything in Homey is working now but i have 1 BIG problem…
The photo tag is not working, when the flow is started ‘when doorbell has been rang’ there is a foto tag card which is available in your flow.
When using this tag card i only get static (snow) picture, rarely i get a real picture, often it works when the flow is run again within a second of the first one.

I tried everything but i cannot get the picture/photo to work, that is a big ‘bummer’ because i use this function to show who is at the door on my TV (using pipup) when someone rings the doorbell, now i see only static snow. Also in push messages and emails the picture is static snow.

Does someone recognize this problem and maybe has a solution?

An other problem i have is not Homey related but Synology related. The nas supports this camera/doorbell but i cannot connect to it, it keeps reporting that it cannot create ‘a snapshot’ duh…

Same problem here with the snow! As far as I understand, it’s not Homey / Athom but the Netatmo API…

Now have a 1 second delay for casting/sending the photo and it’s usually fine

Yes i have a 1 second delay, but still static snow in the whole flow (push, pipup and email)

I tried, 1, 2, and 3 seconds. Still the same :frowning:

Hmmm the bell seems rather useless to me at the moment if i cannot get any screen/snapshot.
I cannot get any snapshot via Homey or via Synology, both do not work.

I rarely use the doorbell as a remote doorbell to talk so someone when i am not at home, i use it mainly for to see who is or was at the door, so mainly as a camera.
If i cannot get a snapshot then this is for me a very expensive doorbell.

I am starting to get the same feeling myself. Because I already returned it once, then it disconnected from my wifi and Ihad to reconnect, and now again something else happended to connectivity.

I got picture but not by using the delay…

The problem is that when the doorbell is pressed it indeed sends out 2 triggers (on 1 doorbell press), the first trigger contains only a static noise/snow image but the second trigger indeed contains the actual camera snapshot!

I had a timer in my flow which prevented that my flow was triggered multiple times within 5 seconds, it only showed/used the first trigger(noise), when i removed the timer the flow was triggered twice and the second trigger showed me the picture (by overwriting the first trigger) on my devices.

I made a support ticket yesterday by athom and they responded to look into this (i advice others to do this also).

For now i have picture, now i need to find a way to only show/use the second trigger until this is fixed.

I added a few cards to my flows, now I get every doorbell press a picture. This is a work around until athom fixes this, it seems this is indeed a bug of the netatmo app
If someone is interested which cards/flow i used to work around this bug, let me know, it is rather simple/easy, it involves 1 logica value and a 3 flow cards

update 2
This work around is not reliable works randomly, so now only can wait on athom to fix this

1 Like

As I understand it, athom is not eager to fix this problem, since it still remains. And they were asked a question 2 weeks ago - and there is still no answer.
How did you solve this problem, what streams did you use to get exactly the photo, and not the picture with snow.

Athom has to fix this as it’s directly by design based on their code, or someone would have to develop community app. I have contacted them repeatedly on this, sadly there is no priority on that…but I will do it once more as there might be some solution but it’s kind of nasty hack.

Here in your phrase the most important thing is that it should, and is not obliged))). Therefore, this problem, like the rest of the little things, will not be corrected, this is already 100%. If the developer has been telling everyone for a year that we will fix it and do not fix it, then this is not worth waiting for.
Here is the answer from ATHOM: “I’ve shared your issue with the image capturing with our Development team, so they can have a look at it. I can’t give any guarantees on when this issue will be found and resolved, but please know that it has been forwarded to our development team and it will be investigated.
We hope to resolve this issue as soon as possible.”

They will, I would bet on it - question is when.

FYI, I already shared with them my dirty hack 5d ago, which works (I can say based on few tests)…so far no reply, but they know me already, so let’s see :wink: