Neo Coolcam V2 PIR registered as a V3 PIR

I bought myself a Neo Coolcam V2 from Bangood. I tried to connect the PIR as a NeoCoolcam V2 but that procedure in the NEO App (NEO Coolcam 2.1.9 from Marco Ruiter) doesn’t work for the Coolcam V2 I use. On the Bangood-site the PIR is sold as a NEO COOLCAM NAS-PD02Z.
When I install de App. PIR V2 is asked for pressing the link-button 3 times in a short period. But the first dot remains blue. And nothing happens. If I take the battery out of the PIR and put it back again, the first dot turns green and the second dot turns blue. When I take the battery out and put it back in again, the coupling is complete. The PIR is then registered as a V3. It detects movements, temperature and LUX, but it is impossible to change settings. when the PIR is registered. I guess this has to do with the registrations as a V3 but actual it is a V2. The supplied manual also describes the operations as a V2 PIR.

What is wrong? On the site of Robbshop I read someting of issues with the current firmware?

Are you sure you have the V2 version?
What product type ID, product ID and firmware do you have?
As far as I know, the product type ID and product ID are used to select the correct device for inclusion, not which product icon you have selected.

Ill go a step further.
I have a v1 that is registered as a V3 and a V2 that is registered as a V1

Product ID 4227
Firnware V3.93
HW version 66

I dont have the V1 PID right now. I connected it to domoticz to see if it was a sensor error.

My three V2 sensors have the following data (can be found in Developer -> Devices):
Driver: NAS-PD02ZE
zw_product_type_id: 3
zw_product_id: 4237
zw_application_version: 3
zw_application_sub_version: 81
zw_hardware_version: 66

In some threads this problem is already discussed, for example here.

For setting on zwave battery devices you have to wake up the device just a second before you push apply on the settings . Known zwave core issue since battery devices don’t wake up that often .

Homey looks at device Ids not what it tells you on the package . So I would trust homey more then the package if it tells you it’s a v3

And banggood sells a large quantity of refurbished sensors . So I could just be a v3 that got send back and they put it into a new box so it looks good again

I’m not sure what you mean exactly.
I installed the PIR more than 5 months ago with the current app version at this time. As far as I know there was no V3 version available at that time, right?
Anyway, I didn’t have any of the known problems discussed in the linked thread:

  • not includable
  • changes in the settings cannot be saved (e.g. motion detector LED)

The only problem I have is that the battery status of 2 sensors is not updated. But that seems to be a general Homey Z-Wave problem, right?

Currently I have the app version v2.1.9 and Homey FW 5.0.0-rc.43 installed.

First V3 was reported in Juni this year so could be V3
Battery reports not coming in is a general homey/zwave issue .

My V1 is a few years old.
But it is really reporting as a V3.

I’ll get you more detailed info tonight if you want.
And since i have a V1 and a V2 that both are not really critical to my flows i can test some stuff for you if u want.

Product id 4237 is the one and should be the only one that’s v3.

I see noted above a 4227 :face_with_raised_eyebrow:
I checked the driver code and that’s not in the v3 driver so could there be a bug in the detection these latest firmwares … are you all on v5 series of the firmware ?

Nope. Im on 4.2
And the sensor with 4227 is reporting as a V1. But it looks like a V2.

My V1 (i dont have it connected now) was reporting as a V3.

The Neo Coolcam I’m refering to is :

Apparaat ID 14
Fabrikant ID 600
Product Type ID 3
Product ID 4237
Firmware Versie 3
Firmware Sub Versie 80
Hardware Versie 66

When I pair him as a V3 I press the button inside for at least (appr.) 20 seconds until the Red Led lights up. Not the 5 seconds in the instruction on the HomeyApp.
I repeat that procedure another time and then it is registered (Paired)
It looks like it is a V3, with a bundled instruction manual for a V2 :thinking:

Adjusting settings in the Homey-App still doesn’t work. I can change the settings and want to save it to the Coolcam but at the end I have the red-bar with a timeout. What is the suggestion to wake up this Coolcam V3? Press until the red LED lights up?

Normally you wake up sensors in the same way as for inclusion.

I removed and re added the devices.
I have a device that should be a V2 but the app sees it as V1
Pid 4227
Firmware 3.93
Hw version 66

And a V1 that is being seen as a V3 this thing is a few years old.
Pid 4237
Firmware 3.80
Hw version 66

Both devices have a working pir sensor (the V1 however needs more movement to detect something)

All other sensors fail on the V2 there is no temp option and lux reports nothing

The lux works on the V1 but temp doesn’t

Its seems strange that my old V1 has the same pid and firmware as the new sensor @Evert_Bruinsma has. Did they just re-use V1 hardware in a V3 enclosure?

What are the numbers for all three PIR versions? I don’t find the V2 info.

PIR v1 ?
Pid 4227
Firmware 3.93 or 3.97
Hw version 66

Pid ?
Firmware ?.??
Hw version ?

Pid 4237
Firmware 3.80
Hw version 66

Pid 4237
Firmware 3.80
Hw version 66

My V1 has that PID. I bought that thing June 2017.

I dont see the real problem… What do you mean it comes as v3.
As you see above it uses the PD02 aka V2 driver … Thats correct

Here is the list of ID’s that should match versions as far as known:

V1 : 4227, 24707, 131, 8323, 8333
V2: 4145
V3: 4237

The looks of the sensor its casing doenst tell anything since neo uses the different cases for every version mixed. So you can have a v1 with a v2 or v3 casing and viceversa.

Checked and correct . But it seems NEO uses the V2 and V3 ids mixed .
But this should not make any difference since the driver is the same.

Conclusion …

If it reports as a V1 . You have a V1 . Maybee in a casing that looks like a V2 . But its a V1

V2 or V3 … Can be any of it depending on the firmware Neo uploaded . Basicly the drivers are the same .So dont care about the default label it puts on the device. You change the name to something logic i guess straight after the add.

Sources checked … Zwave alliance database
And the latest openzwave

I think there is a misunderstanding here.
You said “It’s coming on as V3” (see post #6). I didn’t understand what you meant with that. And I don’t have a problem with that. So everything is fine for me.

The other problems that started this thread was poor zwave reception and not knowing to wake up the device for settings .

So I guess this thread can be closed :joy: