NEO Coolcam Pir v2 not updating status

So, just received my Neo Coolcam Pir v2 (it IS a v2) but i’m having some issues with the device.

Temperature and Lux seem to be updating…but the motion alarm never turns off (in homey)

Tried the stable version of the neocam app and the beta.
restarted the app, re-paired the sensor and restarted homey itself.

My sensor is detecting motion for 2 hours now :wink:

Does anyone have any pointers for troubleshooting?

Advanced settings > Motion detection On time ?

1 Like

yeah…that’s set to 30 seconds :stuck_out_tongue:

What is the distance between the sensor and it’s nearest powered zwave device? I had this also with a pit v2 and i noticed that the range is terrible so I needed to add a powered device in between homey and the pir. And this is for 5 or 6 meters with some walls in between.

I used a domirext lightbulb as the hub for the pir

Hmm… The distance is about 10 meters (line of sight, no obstructions)

I ordered one to test as a replacement for my xiaomi aqara sensors… But so far I’m not impressed…

I have to say that 10 meters quite the distance. Neo battery powered devices don’t have a big range from themselves in my experience. Also it’s not only the distance and obstructions but also things like other networks / radio frequencies etc etc.

That’s why I added a powered device in between

Hmm… Perhaps I’ll have to buy a z-wave range extender…

Seen one from Aeonlabs… There goes another 40 euro’s :stuck_out_tongue:

1 Like

Just buy some power plugs, they do the same but also can use them for other things. My advise place at least 1 main powerd device in every room.

Buy a simple neo coolcam smartplug from ali. Much cheaper and does the job as well

Hmm. I have the same problem with the Fibaro one. Maybe bot of the apps has a (same) bug?!
The distance to the next powered z-wave is 1,5 m…

I have a Fibaro Dimmer 2 in the proximity of the sensor…

however, the coolcam is not meshing with it…do i need to change something for this to work?

This thing is driving me nuts :frowning:

Got the same issue here! I’ll try to add a powered device too.

Can you wake it up ( just be sure it’s triggerin) and hit the ‘heal’ button on the right for the keuken spots device?

I recall something about security-protocols for Neo being not the same as for Fibaro :thinking: so secure meshing didn’t work… @MarcoRuiter wrote something about it short while after Neo became available for Homey…

1 Like

The new versions of the neo device like plug wr02 have sha Security and mesh with other secure devices

1 Like

implying the older ones don’t ?


But do mesh with non secure

As far as i can google Z-Wave plus devices should be able to be added as non-secure device. (i know very little about z-wave; still learning)

Does anyone know if this option is already implemented on Homey (or on a roadmap?)

Little update; it worked!

  1. Woke up the PIR-Sensor by pushing the button 3 times so the led starts blinking.
  2. Giving the heal command to my Fibaro Dimmer 2

This allowed the PIR-Sensor to use the Fibaro as router.

Thanks for the tip @Jeroen_Somhorst!