Neo Coolcam PIR not (?) switching on when the room is crowded

I have flows that are triggered by a neo coolcam detecting motion. The flows then start a down counter with value 1800 and when that counter is at zero (meaning no motion has been detected the last 30 mins) everything is switched off, including lights, radio etc etc.
Now this normally works fine, but it happened already a few times when I had the room full of people somehow the room goes dark and music switches of. :weary:

My theory is that the PIR is detecting motion all the time and thus it stays in the state motion detected’. So the transition from no-motion to motion never happens and thus the flows are not triggered. BUT…
Wouldn’t the blind time prevent the the PIR from staying in that state forever?

Has anyone experienced the same problem as I have? If so how did you solve it?

If you longpress the device tile, you can view the motion:true and motion:false events timestamps, by pressing the = icon

Can’t you trigger on the transition from motion to no-motion?

That seems like it was fixed by many, many people now by thinking the other way around like this topic explains.

1 Like

Yea i can, but as I describe i don’t think that transition is happening. Since there is constantly motion detected.
Also i just noticed that the ‘blind time’ is always smaller than the ‘on-time’.
So this probably means that direct after the ‘blind-time’ and before the end of ‘on time’ it detects motion again and just stays on.

Browsed through your link but didn’t see anything describing my specific problem

I guess the solution is that when the counter is zero AND the PIR is not in ‘motion detected’ state Then the lights must be switched of. Else the counter is reset again

1 Like

The counter in this example is only started when the PIR sends End Of Move !!!

The first post in that topic is meant for the same issue as you are describing, the light turning off while there is still motion.

It is exactly as you are already describing too, the motion will stay on if there is/was motion before it is cancelled, you can lower the “cancel” to something really low (on some brands), but even that well not always catch that when there is a party going on with dancers, or just movement all around.
The blind time setting is just to save battery on sensors, I believe most brands don’t allow to have it lower then the cancellation time, it will still only cancel when the blind time is also over.

So the topic I shared explains to start the timer on when the motion turns off, instead of when it turns on like you are doing now.
And stops the timer again when there does was a motion sensed again.
It does take 1 extra flow, but solves 99%+ of all cases where lights turn off when there is still motion going on.

In the end, you could also choose the “zone becomes inactive for …” trigger card, as that also has a 30 minute option, that only has the limitation of the limited amount of “inactive” time options.

Ah… on second thought you might be right. My apologies for being a bit stubborn and not reading thoroughly enough.
I understand now the different way of thinking, have to give that another thought before doing the implementation