Memory usage 8.0.2 (early 2016)

After installing 8.0 (8.0.1-8.0.2) firmware i see a huge memory increase. After a while apps get “pauzed” and only resetting or ptp solves the isseu for a while. Someone with the same issues?

Fresh restart

After two days

It is a temporary overview. Better look in Insights to view what’s happening. Apps should not get disabled. Which apps ?
Screenshot of my Homey memory usage
(for a 2016 model it should varying around 130MB - 200MB), and of an app which reached 100MB’s and killed Homey as well (it just restarted):

I was fiddling with Aflows and the error tags. I noticed all slowed down a lot, until I saved the flow and went on editing other stuff.

1 Like

After updating to v8.0.2 I had the same experience, however a reboot (no PTP!) seems to have solved the problem again:

Actual screenshot (7-day overview):

at least u can load that page. for me that is already for years not possible anymore :frowning:

I know the struggle. Many times i also get an "
unavailable page"

@Edgar @wesley_w That is odd…

Maybe this helps:
logoff of all Homey related sites and Homey itself, clear your browsers’ cache and cookies for * and *
and then log back on

Similar issue like TS. After latest firmware update on early 2016 homey.

Looks like homey is constantly restarting. As soon as it is back online, all apps are pauzed and one by one they come back online again.

You only notice when a flow does not start, or is partially executed.

thnx Peter. But what has cookies on a website to do with the iOS Homey app?
however, i tried to log off from the app en log back in and that worked (for now). :slight_smile: thnx!

i bet i have to less memory :slight_smile:

1 Like

While Insights are displayed in a web browser

[off topic] insights can’t be used in the iOS Homey app… cookies are stored locally in the temporary internet cache of its client and has nothing to do with server side services. that is exactly why they are invented because in the early days they used server sessions. that use server resources :slight_smile: and was too hard for servers… so… cookies were born, resources spread over clients = less resources for the server.

Cookies are still used in combination with serverside sessions, where the cookie just contains a session ID. Because of their size limit, you can’t really use them to store actual information.

That is nowadays indeed :slight_smile:
But cookies in a browser of a client has nothing to do with the homey iOS app…


That is what i am saying. But logging out and back in in the app itself worked so i could also send athom a diagnostic log

Well, I’m no cookie-master, Edgar, but I know logging out of all and delete and remove all Homey related browser and app data, does some magic every now and then! :sweat_smile:

well… see it like this: ur car is running on fuel but it ran out of it… it doesn’t matter if your house is clean or not… ur car still needs the fuel so u have to refuel… :slight_smile:

clearing cookies and cache is only necessary when u have issues with a browser.

Ok thanks all…fot this tasteful kookie information…anybody else with a memory buildup that will slowdow homey and pause apps until you need to reset it?

Never mind my previous post.

After several attempts to restore the homey, it started buzzing and showing a multicolor weak led ring….think it is time to say goodbye.

Behavior just before death:

  • constantly restarting (homey and then each app needed to restart)
  • losing connection after a few minutes
  • difficult to get in recovery mode
  • not able to connect to wifi
  • loosing connection during recovery

This has all the hallmarks of a failing Athom power supply. Try replacing it with something better (5V, 2A minimum).