LAN adapter

I have connected the LAN adapter to the Homey pro 2023 according to the instrux. I can see in Homey hub setup that the hub is connected both to wireless and cable with different IP addresses. My Router is also connected to wireless and cable with respectively IP addresses. Why both connections?

Enter setup mode and disable wifi

1 Like

The question is if it is any problems with having both a wireless and a cable connection between Homey Pro 2023 and the Router? I suspect the cable connection is prioritized before the wireless connection - or?

Emile wrote somewhere (but I can’t find it atm…):
If you have both adapters enabled: when the LAN connection is up, the wifi connection is inactive, and whenever the LAN connection goes down, it gets activated as a kind of failover connection. Check it out by pulling the cable out!
It should work fine having both enabled.

1 Like

Thanks Peter, You are absolutely right and, yes, that is what I hoped for and it did work just fine to knick the cable and put it back. It is just how my Router works handling fiber and mobil net connections with double WAN fail over. Of course, the probability that the cable connection should fail is very low - it is rather the wifi connection that is in danger to fail, which it has already done. The reason for my Homey hub wifi connection to fail is still a mystery to me. Could maybe have been overheating but I do not know.

1 Like

You’re welcome, Nisse.

The Homey wifi implementation seems to be very picky (like the previous generation :wink: )

I think for the wifi connection to be stable it’s important to:

  • reserve an IP for the wifi MAC on your DHCP server
  • Keep Homey a few meters from a wifi AP or wifi router
  • Check were Homey sits, while it’s antenna’s are located at the bottom
  • Also, don’t put Homey on top of a speaker or amp or the likes (I’m sure you don’t, but it happens :upside_down_face: )

When you have a wifi mesh system:

  • “Glue” Homey to ONE AP by using band steering / MAC filtering / tuning transmit power

When it’s overheating send it back to Enschede I would say
It should throttle the CPU speed down when it reaches 85°C

Are we talking about the raspberry cpu with a temperature warning at 75 C? I don’t think there is a heat sink connected to the cpu, which is recommended. The cpu is said to be easily overheated and throttling. However, does this situation affect functions like wifi? Is it possible in any way to check the cpu and motherboard temperatures, like it is for PC motherboards and cpu:s in any system information tool? Since the Homey is constantly working an overheating can be a problem. Is it likely that the motherboard and other electronic parts could take a beating? Like it is mentioned above, 30 C is not unusual this summer.

It’s in the topic I linked to. A CPU without heatsink wouldn’t survive the testlab…
It is a very minimal heatsink though, for a closed box…

Hi and thanks again,
Overheating is obviously a serious issue with Homey. So, the best idea, to keep the warrranty, would be a peltier element and a fan which will be a cheap solution to the problem.

Hope I can tag along on this thread, as I have just connected an Ethernet-adapter, and mostly just getting WiFi.

I did a soft reboot, and it actually picked up an IP#, then it crashed.
After another reboot, I am back to WiFi only.

What’s going on here?!?

You should probably ask Athom.

…and yet I am asking the community first.

Someone might have had similar experience without having to RMA the LAN-adapter.

Carsten, about the ethernet adapter, are you sure you connected the short fixed USB cable to the power unit, and the long cable to Homey?

.
When yes, but without improvement:
Did you try to replace the USB cable with a decent quality one?
While there seems to be a number of bad quality cables included to some delivered units

And what if you temporary disable wifi? It shouldn’t make a difference, but it can’t hurt to try different setups.

And yes, there are cases of DOA ethernet adapters, so, it’s possible you just recieved a malfunctioning one.

Homey crashing when it gets an IP address is really something that Athom needs to know :man_shrugging:t3:

1 Like

As You may see in this thread I had serious problems with wifi connection between Homey (early 2023) and my router, so I decided to cable up the connection with the adapter. I used a one meter flat cat 6 quality cable. First I disconnected Homey and I turned off my router. I connected the network cable between Homey and my router and turn on Homey and then the router. When rebooted I had one wifi connection with the same IP as before and one IP for the cable connection. So now I have two stable IP:s - one for wifi (in case) and one for the cable connection. I have no binding to any unit in my mesh system and no fixed IP or any special set up in my router. And, a top that, I have no idea why it works so well, but since I cabled up the connection I have had no problem with the connection.

I guess we’ll see you back when Homey gets a new IP address from your router and suddenly you start getting “Homey offline” errors :wink:

So far, so good, since high summer July. Despite several reboots, firmware updates and new devices installed, I have had no problem so far (with connection to Homey that is). But I am sorry Homey Athom Company can’t help You with Your problem as they couldn’t help me with mine (getting Homey offline now and than). Of course I have had a lot of problems with different devices and their IP:s… But in some way or another the problems have been solved and by router DHCP server activated assigning the IP address. Sometimes hard reboot has been necessary to regain connection.