Issues Setting Up MQTT For HASS

@Gustav_Tillback thank you for this summary although i guess it is not noob-proof :wink:

I’ve managed to get the broker up and running with the scanno Athom app. I (guess i) configured the MQTT Client app but i am not sure if i filled in all the correct fields. In the log i can see a lot of message activity (SendMessageToTopic) which should confirm some kind of broadcasting (i’m a complete noob).

In the MQTT hub, under devices, i keep getting a spinning wheel and no list of devices.

At 5) in your summary i guess i need to configure a new MQTT integration with my Homey IP address without username and password? As expected it is saying there are no devices.

Obviously i am missing a lot (and do a lot of guessing as you might have noticed) :rofl:

Could you help me in the right direction?

@Ferry_van_E what what’s your Homey firmware version? Some reported issues with 2.0.5rc5…

Hi @HarriedeGroot

I’m running on 2.0.4

Wow @Gustav_Tillback ,

Thats is more than i hoped for. I’m going to try this! Thanks!


Thanks @HarriedeGroot

Could you reproduce the issue? Since i am a noob i cannot confirm i did all the correct actions to properly set it up

@Ferry_van_E No, I couldn’t reproduce, but have it confirmed working by @KonradWalsh.

Someone any idea how to do this? Every search result leads to but i have set up Docker on my NAS and used the available MQTT broker and Client available for Homey and the MQTT hub.

In HA i can choose MQTT from the integration list where i fill in my Homey IP on port 1883. The message that comes up is that there are no devices for MQTT while i expected to discover the same list as shown in the HUB.

I’ve tried to do a forum search but the main MQTT hub thread has like +500 replies.

Thanks in advance

**i’ve ran into the settings below. First the configuration.yaml needs to be modified as shown below in order to set up the integration?

A complete tutorial would be nice.
Still no device is showing up in HA :expressionless:

30 39 51

I have the same problem, everything is set up in homey. Broker, client and hub are running. In the hub I see every device.

Selected the auto discovery for ha. But nothing is showing up in ha.

Ha is running on my Synology Nas in docker.

Do i miss a step in ha? To connect it to homey?

1 Like

:joy: I guess we are together in this @David_Maas
If we manage to get through this we could maybe write a tutorial :ok_hand:t4:

1 Like

@Ferry_van_E & @David_Maas Did you guys enable Home Assistant Discovery in the MQTT Hub app settings?
And do you see any messages in MQTT Explorer?

I already enabled Home Assistent Discovery in the MQTT Hub app settings.

MQTT explorer is new to me so i have to find out first how to generate the info that you are looking for.

Thanks for helping us with this. I can imagine that this, for you as a next level developer, can be a bit exhausting to cope with people who have like 5% of your competence… :speak_no_evil:

1 Like

It’s part of the ‘journey’ :slight_smile:.
Before you know, you’re the one with 95% of the knowledge and explaining others how to get things up and running :wink:.

1 Like

So i’ve installed MQTT Explorer on my iMac. HA is running in Docker on a NAS.
See printscreens. (i probably did not fill this in correctly since i, again, expected to see something different)


What’s the configuration of the MQTT Client? Is it successfully connected to the broker?
And did you try disabling the certificate validation (depending on the broker configuration)?

See screenshots below. In both cases no username and password

Try turning off authentication (Authenticatie van gebruikers uitzetten).
Of course it is wise to configure this properly eventually!

Small question aside. All devices must show automatically in HA? So no hassle for extra setups? Or do we still must setup a connection in HA?

Just checking if i’m still looking in the right direction :slight_smile:

Yes, after enabling mqtt discovery in HA, all devices should show up automatically.