Issues Setting Up MQTT For HASS

Side step: I prefer using an external broker to reduce the workload for Homey.
Therefore I configured a Mosquitto broker in a docker container on my NAS.


Indeed, this is the next step because I saw the workload. But for now trieing to setup the noob version in Ha so I can look if it something for me :slight_smile: Many thank in advance @HarriedeGroot

So, i disabled the MQTT broker on Homey and installed the Mosquitto on my NAS and opened MQTT explorer

Checked the configuration.yaml for discovery

Now you need to point both the MQTT Client & HA to the Mosquitto broker.

I did for the Client on Homey

Where in HA can i point to the Mosquitto broker?

See: Run your own:

FYI: Above is resolved by disabling the secure connection (TLS) in the MQTT Client.
Of course its advised to setup a secure connection.

Hey @Ferry_van_E, perhaps I should have been clearer about it being time for a new thread.

I’ve moved your posts from the Tablet wall-mounted controller for the home thread and created a new thread for you in Questions & Help.

Please try and keep conversations ‘on topic’ with in threads, and create new threads for ‘new topics’.

There is valuable information here which others may find useful, it having its own thread make it easier for others to find.

If you would like to discuss this further please feel free to contact me.

@Ferry_van_E Maybe i have found something. When i look in HA under developerstools/information the log says: Unable to load /config/known_devices.yaml: Config file not found: /config/known_devices.yam
Also i cannot find the file in the folders, so it looks like it has a problem creating the right file.
I tried a older version for Ha, but still the same problem.