Installing Shelly app makes homey unresponsive

When i install the shelly app on my Homey Pro it stops responding. It looks like it’s restarting constantly. I have only a couple of seconds to go into the settings/apps and uninstall the app. Then everything works again.
I wonder what could it be.

I have 11 apps installed and about 25 devices (some of which are virtual devices and a weather app)

Reason for installing the Shelly app is to control 4 LED bulbs and a 2.5 roller shutter.

And when u give Homey more time to start up, 30 minutes orso to became stabel again…

I’ll give it a try. Just installed again (time: 9:10) I’ll check later this morning.
It does look like the Homey is constantly restarting though.

Nope, it’s even worse (i’ve waited over 2 hours). Before, I briefly could access the apps menu and uninstall the shelly app before it went unresponsive again. But now it isn’t responding anymore.
I will reset the homey back to factory settings and restore a backup.

Try different power supply for Homey with min 2A output. It sound strange, but the original is causing a lot of problems.

A different power supply didn’t solve my problem. I have reset the device to factory defaults then restored a backup from a couple of days ago. Everything works fine. Then i installed Shelly again and from that moment on Homey is again pretty much unresponsive.

Have you tried installing other apps to make sure it only happens with the Shelly app? (FWIW, I just installed the Shelly app and I can’t reproduce the issue myself)

Yeah, i’m beginning to think it is a combination or order of installing. Going to go back to a later backup and see what happens. Eventually i will start all over again with a clean setup.

I had another user report this. Even after extensive debugging the cause was never found. See this for more information .

If you see some pattern or fix the issue, please let me know.

Ok, i just did a complete factory reset and installed shelly as the first and only app. No results… No idea what i can try next…

You should at least report this to Athom. I’m not a very good coder but my app is pretty simple with only two node module included. There are over 1400 other users using the app without issues. There must be something fishy with a handfull of Homeys and/or their network configuration causing this issue.

Yes, i already did that. But i have some more info. My Homey starts responding when i switch off my internet router. I noticed in the settings/general tab that the cloud status was switching between handshaking and offline. After switching off my router it the lead average drops from over 2000% to 10%.
I’ve switched on the router and am waiting for the homey to connect to the cloud again. I’ll keep you posted.

Looks like it’s working now. After resetting my internet router everything started working again. For some reason the shelly app triggered a network congestion or so. The homey utilization went through the roof.

The Light bulbs are working fine now.
Next problem: adding the Shelly 2.5 roller shutter fails with the message: the shelly device you are trying to pair does not match with the selected shelly device in the pairing wizard

Does that sound familiair to anyone?

Well, it seems that the pairing problem with the Shelly 2.5 roller shutter also had to do with my internet router. And specifically the WiFi part of it. When i switched of the WiFi and connected to the internet using another access point i was able to add the 2.5 to Homey. So all is fine now and I’ve learned a lot (about my router :wink: )


Damn, received an update of the shelly app today. It restarted after the update and my problem mentioned above is back. As soon as the Homey has internet connection and i enable the Shelly app it stops responding. If i enable the app without internet connection is works.
I installed wireshark to try to see whats happening on my network. The only thing I see when internet is connected is that a lot of mDNS pakets are sent. Disabling the Shelly app gets things going again.

The mDNS messages are used during pairing to discover the Shelly devices. This functionality is part of Homey core and I dont have much control over it but I would think the mDNS message would only be send during the pairing of devices. If you are seeying a lot of those on startup of the app I’d say there is something wrong with the way that works. Perhaps this is something to report to Athom if you have a wireshark log to back up your case (they will most likely blame it on something else otherwise).

Thanks, I will do that. In the meantime i’ve created a diag reoort for you 354fe140-c5db-4690-863f-a6d0b02f613a
I’ll also create one for Homey.

That log contains a lot of request to failed, reason: connect EHOSTUNREACH errors for various IP addresses. If you have static IP addresses and you are sure they match the Shelly as paired it’s Homey struggling with it’s network stack (which may be explained by the heavy traffic on mDNS broadcast messages).

Thanks for looking into that! This helps…
I’ll continue my search and keep you posted.

Have you found a solution for this? Seems like I have the same problem.