Innr FL140C integration

Hi everyone,

I’m new to the forum but I’ve been using Homey for a while now. I posted a review on the innr app about the innr FL140 not being compatible with the app. The developer replied saying I should get in contact on here, but to be honest I’m not sure how to contact them!! :joy:.

Anyway my problem is that when adding an innr FL140 light strip, it is only added as a generic device as Homey reports that it doesn’t know what it is. Has anyone else managed to successfully connect an FL140 to Homey? Or is anyone having the same problem?


You can contact them by mentioning them, like this: @kasteleman

The FL140 doesn’t seem to be supported by the app (yet), so it will be added as a “simple Zigbee device” (which only has on/off capabilities).

Thanks Robert

@kasteleman I own 2 of the FL140s and I’m very happy to help troubleshoot the problem with you.


I’m a little confused concerning the exact product you want to include. Therefore can you provide a screenshot after pairing it as a generic device? In need the product-Id etc. Because you stated FL 140 C. I know the OFL 140 C but not the FL 140 C

Here is the screen shot after the pairing process. Is this what you meant?

The FL140C is the newer version of the FL130. The OFL140 is the outdoor version I believe, although I’m not too familiar with it myself.

@Stud101 I missed that one. To be sure, what Homey Firmware are you on?

Homey version 4.2.0
Innr version 1.1.22

Let me know if you want me to run any alpha or beta tests for you. Happy to help!

are you familiar with cli to side load application on to homey? I pushed new version to GitHub:

Sorry no I’m not. Happy to try though. Just need a bit of guidance as to what to do!! How do I do it?

I’m struggling to do this I’m afraid. I can’t get the permissions right in terminal. Have tried for a couple of hours now. But I keep getting errno: -13. I’m an administrator and I’ve opened up everything but still no dice. Sorry. Is there a different way?

The only different way is that I push it to the App Store. But have to do that tomorrow tho!

Ah ok. Thanks for doing this so fast. I really appreciate it.

This is now fixed and updated as part of the innr app. Kudos to @kasteleman for the quick fix and turn around. Thank you :pray: