Ikea Zigbee

All is running normal except for the Zigbee lights from Ikea Trådrfrï. Since a couple of days they just stopt talking to homey! :scream: Now when i want a light turn on I need to get up and walk towards the switch… And push it like a cave person!!
I hope a simple update could fix it.
Please don’t tell me I need to reconnect all the lights (24 of them) because the ikea Trådrfï app doesn’t work either.

Also I’ve rebooted Homey several times. But the lights don’t reconnect!
And of course Athom doesn’t reply to the mails :disappointed_relieved:

Please help me with this monster of a problem!

1 Like

I have the same issue since two days ago (also gotten lots of red ring of death last few days). I think it is the node update. Several other apps also has the same issue :’(

If you have 24 lights connected to Homey you may be running into the 20-device connection limit. Try pulling the plug on Homey for about 10 minutes and remove the power of about 5 of those lights and see if your Zigbee mesh comes back up again when you reconnect Homey to power (while those 5 lights are still powerless). It may take a while, up to 20 minutes, for the Zigbee mesh to settle.

Also, what do you mean by “the IKEA Tradfri app doesn’t work either”? Does it crash?

In my case:

All my zigbee apps (gledopto, ikea, innr and xiaomi) all have all devices with spinning icons.
If I click option on a device it says “Device starting…”.

If I go to zigbee page in the app it “hangs” (i.e. spins).

If I go to the zigbee developer page https://developer.athom.com/tools/zigbee it also “hangs”. Seems the state endpoint (https://192-168-161-10.homey.homeylocal.com/api/manager/zigbee/state) is stalled and never returns anything.

I have restarted and factory reset my Homey (as I have also been getting red ring of death whenever I try to add z-wave devices).

// Michael Medin

This is the IKEA App. All devices loading when I click it.
And is has been working for weeks on end before. Of course the usual restart every now and than…

But I’ve pulled the plug and am patiently waiting now.

Is there a 20 device limit on zigbee??? I have 30 installed! How can this be. I thought it was a limit for battery powered zigbee devices or am I wrong?

There’s a 20 device limit for devices directly connected to Homey.

Have you tried a different power supply?

Yes, switched to a 2.3Amp right now and I dont get the red ring of death last few days, but then again have disable 4-5 apps so that could be it also…

But doubt that has any impact on the zigbee issues, seems more likely something broke in the latest firmware as it has been running fine for years…

Also the hue app (gateway i.e. non zigbee) started to use 50+Mb of RAM around when things went to haywire:

So my bet is on the latest firmware (or restoring from backup after the factory reset) and apps gpoing haywire caused the system to use more power which caused the red ring of death (which happen hours after boot)…

// Michael Medin

For me killing the power for 10 minutes did the trick! Thanks Robert! You’re my hero of the day!!

1 Like

ahh now i understand it better as i have 30. only 11 directly to homey so i can add a lot more :joy:. Whats weird is that the light bulps of ikea do not act like a router at all. The INNR bulps seem to work fine as a router also the OSRAM plug works as a router. Is it normal that the ikea bulp do not work as routers?

A lot of my Xiaomi sensors are being routed through IKEA devices (bulbs, repeaters, LED drivers).

Strange, the only reason i can make up is that my INNR light bulps are closer to homey.
Maybe thats the difference than in my house?

Edit: i tried to see the logic behind this but there is any. I looked how the end devices are routed thru the routers and compared the distance to homey bit this is not logical at all. So it must be a coincidence that not any ikea is used as a router.

I added one myself last week and nothing happened in the routing table at first, even not after several days. It seems Zigbee devices do not change the existing route by their selves.
Only after i added devices closer to the routing device than to Homey yesterday they finally showed a route through the router.
Don’t know for sure if that is expected behavior or just a coincidence.

Yes they do. I regularly move Zigbee devices around in my home, and they find new routes usually within minutes.

Then i guess they all think the direct route to Homey is suitable because even after days nothing happened. Not even after a PtP.
Will wait a few days and see if they switch back to a direct route to Homey.
I hope not, because if that happens i immediately will start to lose devices because i’m well over 25 devices now.

With a proper mesh, devices can be connected to multiple routers at once. I don’t know how the Zigbee routing table in Homey is generated, but it can’t show the whole picture given that it will only show one route for a device, even though it might have several routes through other routers.

1 Like

Then maybe it is because the router was added as the 20st device at first.
When it didn’t work at first I removed the router and some devices that were not used in flows, added the router first and then the devices close to the router and now it works beyond the magic 20 limit.
Hope it stays that way though. :thinking:
Will try to move one temp sensor to another floor and see what happens.