Ikea tradfri smartplug both Homey and 1/0 switch possible?

I have the tradfri smartplug with the 1/0 on off switch.
Use the Ika Tradfri app
Can connect to the app: no problem.
Can connect to the switch per manual instructions: homey connection is gone
Reconnect to homey: switch connection is gone
Cannot find the switch seperately in the app, all switches there let me press the connect button 4 times in 5 seconds but this one wants a long press for smartplug connection.
Is there a way around this?

Have you actually tried doing what’s being suggested, i.e. pressing the connect button 4 times in a row? Because that’s how you put the device in pairing mode.

The long press is used for TouchLink pairing, which is not what you want.

Jup, tried them all but the switch is not there as far as i can see. The only one which looks the same is called a dimmer switch.
Pressing the connect button four times does nt blink or burn any light and does not result in installation.

The device I linked to is the ON/OFF switch, which is the same as yours. I have a few of them and I can put them in pairing mode with the suggested method.

The type of your button should be on the back, is it E1743? (and if not, what is it?)

Yes I have the E1743
It now succeeded by pressing 4 times within 1 second cq as fast as possible in stead of the 5 seconds. That’s the problem with many variables. If you’re not sure what you’re doing you don’t try hard enough. Maybe the instructions might be updated as well. If I read press 4 times in 5 seconds I think it’s good enough when time between presses < 1 sec.

Thanks for reacting.