Ikea Trådfri dimmer problems

Hi.
I’ve had my trådfri devices running smoothly for a while. Then it stopped working. I can adjust the lights from the app. The flows work when I test them, but my dimmer doesn’t seem to work. So I tried adding it again. Everything went smoothly during pairing, but still nothing happens when I rotate it. So I made a flow reporting on rotating stopped. Nothing. So I checked the battery, which had a 2,97V charge. Should be fine. So I added it to my trådfri hub and it worked fine. Removed it from the hub thinking maybe it just needed some love, but when I add it to Homey again nothing happens.

Anyone know what this could be? Doesn’t seem like the device is faulty and the battery charge seems fine.

Did you kiss it… :kissing_closed_eyes:

Maybe a distance problem, did you tried it when its close to homey. Restart the app,? PTP of homey?

Think the batt is ok, because you said its working when connected to the Ikea hub.

The Homey is about 3m away. I’ve even tried using it 5cm away from the homey. No dice. I’ve tried restarting the homey several times. What’s PTP?

Pull The Plug, and leave it out for 10-15 minutes before plug it in again

Can try that. Only left it for a couple of minutes while I moved it to be closer to the dimmer and lights.

Unfortunately, that didn’t help. Got any other ideas? Seems strange as I can control the rest of my Ikea devices through the Homey - although this is the only one using Homey’s App. The other Ikea Trådfri Gateway app.

Tried updating to the beta version of the trådfri app, but no luck. Unfortunately, the trådfri gateway app doesn’t seem to handle dimmer events well…

Maybe try a fresh battery. To make sure it’s not the battery.

Thanks. I checked the battery. Replaced it a couple of months back and it was still good. Working like a charm with the Trådfri Gateway.

What do you use the dimmer for? I’m having problems with mine as well!

Please tell Athom at support@athom.com . I’ve logged my problems as a ticket and they’re looking into it. I want to use my dimmer primarily to control the bedroom lights, but it can be used for pretty much anything. Since you can read the “value” from it, you can use it to dim lights, control power to devices and even temperature control. If it works, that is :wink:

Same issue. Got 2 ikea dimmers, they don’t do shit. Worked for like a week. I don’t have a tradfri bridge, so can’t test that

Anyone solved this problem? I ad my wireless dimmer but can’t work any flows with it.

I have the same experience, I thought I might have maxed out my zigbee devices…

Seems to be working fine with a Bridge, can activate flows but the dimmer functionality is just shit… If you pair them directly to a smart light they ramp up and down when you keep the button pressed. When connected with Homey you need to release the button, so either short press it or long press it and release in between. (depends on your configuration)

But there seems to be no way to have them slowly go up or down.

I don’t think any Zigbee controller can support this, because it just receives button press events (“short”, “long”) from the device. However, with better featured Zigbee implementations, you can bind a remote directly to a light (or group of lights) so the dimming works on the Zigbee level and doesn’t have to pass through the controller. But Homey doesn’t support this.

I just replied in another thread regarding this. Seems to be an issue with the Trådfri App on Homey’s side.

I have the same problem, and have found out that it is the latest firmware, or at least a newer firmware issue. I had a dimmer that hasn’t been updtated in a while and it works fine. I haven’t connected it to my ikea bridge so i don’t know the firmware that works. I have reported this to Athom