Ikea remote and extender cannot connect

I have seen another post lately with the same problem, but there wasn’t a whole lot of activity in that thread (Pairing IKEA Tradfri)
I pledge that someone can help with this issue:

The problem
I have tried at least 30 times now to add the Ikea Trådfri Remote and Ikea Trådfri range extender, without luck.

The things I’ve tried
I have the official Ikea Trådfri App (with blue icon), which is supposed to support both the remote and extender, and try to add them through this app.
I followed the setup process point by point:

1: add remote throught app
2: push pair button 4 times on remote, until i blinks
3: they should now pair (right???)
Nothing happens :frowning:

I tried to add a Xiaomi zigbee smart button without problems, so it doesn’t seem to be a Zigbee issue?

What the heck is wrong? Why can’t i connect Ikea remote and extender?

Am I pairing it wrong or what?

I’m on Homey firmware 6.0 and Ikea .1.8.4

Please give me some advice, I’m so frustrated :confused:

Tried having it very close to the homey?
4 times quick and it should go in. Just did it with mine two days ago.

The signal repeater is a bitch sometimes, but got it in after many tries. Just follow the recipe.

Thanks for reaching out :slightly_smiling_face: It’s placed within 20 cm. Even placed it on top of homey several times without luck :pensive:

Then I’m not sure, have you restarted your homey to see if that helps?

Here’s what I’ve tried :

Tried to restart several times.
I’ve even kept it off for 1 hour.
Also tried to uninstall and install ikea app.
Tried to move homey away from my mesh node and other zigbee devices
Tried to hold remote close, far, on top of, besides, underneath homey during setup.
Tried another remote without luck

I’m getting so f…ing frustrated. What the h…ll is wrong with this?

Do you have a hue bridge you can try to pair it with and see if that works?

What have you already connected in zigbee?
Did you reset zigbee after upgrading to v5 or have you still zigbee devices connected from before v5?

I’ll try that today just to see if it works

I have 15 xiaomi devices connected, a mix of temperature- and door sensors and a couple of smart buttons.

All prevoius devices all work wihtout problems. I haven’t reset Zigbee since V5. Should this even be required? I mean then I would have to re-add all devices againg right? That seems like quite a hazzle :confused:
If that’s what it takes I’ll have to do that, but it really seems cumbersome to go through.

Ok, you need more routers and need to remove a couple of battery sensors first but I would suggest to do a zigbee reset and start over with adding the routers first.

Pls read this


Also: don’t pair devices near Homey, pair them near the location where you are going to use them.

Ok I guess I’ll have to do that then :confused: . I was hoping to avoid the whole setup process again. Like I said, it’s cumbersome, and seems rather silly, that you have to reset part of your entire setup, to make things work again - oh the joys of smart homes :smiley: (“and ooooh the zigbee”: quote Paul Hibbert)

I’ll keep this in mind as well.

Thanks for helping me out, and confirming I need to start over with the Zigbee setup, although it wasn’t what I was hoping for :slight_smile:

I’ll give you an update once I tried it.

I found the other link I couldn’t find this morning

The good:
So resetting zigbee network made it possible to add the ikea remote.

The bad:
Now i have to re-add all other zigbee devices, and setup all flows with them again

The awesome:
The homey community came to the rescue again. Thanks for all the suggestions. :ok_hand::muscle:


Hi guys! I’d like to have some help if possible. I’m trying to add Ikea wireless dimmer and up and down remote to my Homey Pro. (7.2.0),( Ikea Tradfri App1.14.2 )

Adding the wireless dimmer seems to work, but when added I can’t trigger any flow with it. Adding the up and down remote doesn’t work at all, it says: Could not find a Homey App for this device, it has been added as “Basic Zigbee device”. The strange thing is, that I have wireless dimmers and up and down remotes, which had been connected earlier and they work fine. I’ve already tried restating homey, connected the remotes to Tradfri gateway for firmware updates, changed batteries in them. What else should I try?

1 Like

Same issue for me with up/down. Any Solution?

Ask Athom (the maker of the IKEA app) to support this particular version of the device.

1 Like