Ikea blinds stops working, (interview button makes them work again)?


I have Ikea roller blinds (zigbee)
Sometimes they stops working, then I remove them and do re-pair.
This gives a lot of trouble as all flows needs to be updated.

Today I then tried to push the “interview” on the Homey developer page.
Surprise the blinds startet to work again. :slight_smile:

Are there any way to make the interview from a flow every night?


I have the same problem. The blinds sometimes stop communicating and the only thing that helps is to restart Homey. Zigbee health check does not display any error. I do not know what to do with that

  1. Maybe this is of any help
    Fixing disconnected Zigbee devices (without having to modify all flows)
  2. What is the distance between Homey / zigbee router device and the roller blinds? Can you add a zigbee smart plug (Tradfri) between Homey and the blinds?
  3. Did you check the Wifi & zigbee frequencies, don’t they interfere?
  4. Did you update Homey to v5.0.2 or up? And did you (optionally) reset your zigbee after that?

1: I have tryed to repair, but when I start a flow then the blinds will do everything 2 times

  1. I have Zigbee repeater in every room (repeaters installed before blinds)

  2. 2.4Ghz = Channel 1
    5 Ghz = Channel 36
    Zigbee = Channel 13 (Maybe I should try to move it to 15?)

  3. HomeyVersion “5.0.4”, I have not reset zigbee, dont know what you mean

Your Wifi interferes with zigbee.
2.4GHz ch.1 is almost the same frequency as zigbee ch.13, so it is a good idea to change your zigbee channel to 20 or 21.
If your 2.4 Wifi channel is manually set, you can do a zigbee reset. It should select a zigbee channel with low Interference.
But then you have to re- pair all of your zigbee devices.

  1. I did not know this effect…
  2. Is the distance between Homey and the repeaters about 4 mtrs max? I don’t think it is the issue. First try to fix your wifi/zigbee channel, that should make the difference
  3. See my reply in my previous reply
  4. [Community Survey] Homey v5 ZigBee Health check and statistics collection (HomeyScript)

ok, so I guess the easy way to fix it is to change the wifi channel so I dont need to repair anty zigbee devices. So the question is would it be ok to move the wifi to channel 10 and keep ZigBee at channel 13?

If I understand the drawing, then it would be moved to each end even there are some mirroring.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 0: logIDInfo ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Homey HostName        : homey-5fcf30ceb4be6e0c8e110fc9
Homey HomeyName       : Michael's Homey Pro
Wifi                  : Kongedam 64:69:4e:77:03:d5
ifconfig              :
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 1: ZigBee controllerState RAW data ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
controllerState =>  {"panId":31586,
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 2: logStatInfo ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Platform              : linux 4.14.15-g3c513a6eca    Node.JS v12.16.1
Model                 : Homey Pro (Early 2019) -     Model ID  homey3d
CPUs #/Model/Speed    : 2 x ARMv7 Processor rev 10 (v7l) - 996 Mhz.
Homey Firmware        : 5.0.4
Memory       Total    : 996 MB  - Free :  136656 KB - (13%)
Data and Time         : lørdag 17. april 2021 23:33:29  Zone   Europe/Copenhagen  [2021-04-17T21:33:29.200Z]
Uptime                : 18d + 16:43:46
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 3: Zigbee Network Data ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
# Nodes               : 11
# Routers             : 5
# EndDevice           : 6
# manufacturerNames   : 2
> manufacturerNames   : ["IKEA of Sweden","KE"]
# modelIds            : 3
> modelIds            : ["FYRTUR block-out roller blind","TRADFRI open/close remote","TRADFRI Signal Repeater"]
-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 3b: routing is an ephemeral state and may change at any time  ]-=-=-=-=-=-=-=-=-=-=-=-=-=-
 # Bad Routes    : 0
 # Routes 0 hops : 2
 # Routes 1 hops : 3
 # Routes 2 hops : 6
 # Routes 3 hops : 1
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 5: Devices active Routing ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
55343 - (IKEA of Sweden - TRADFRI Signal Repeater)
27687 - (IKEA of Sweden - TRADFRI Signal Repeater)
42399 - (IKEA of Sweden - TRADFRI Signal Repeater)
28420 - (IKEA of Sweden - TRADFRI Signal Repeater)
63332 - (IKEA of Sweden - TRADFRI Signal Repeater)
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 6: Zigbee Health Advices ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Curently no advices
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-[ 7: Zigbee Reporting Data ]-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> reporting :  0,"00124b0021123364",3,false,"Homey Pro (Early 2019)","5.0.4",0,13,0,2,"2.6.3",11,5,6,2,3,5,false,"#",0,2,3,6,1 , $

Wifi ch.11 & zigbee ch.13 is a good idea.
Changing your zigbee channel manually “could” cause some lost devices, but they should be able to switch to the new zigbee channel.

If you want to change your Wifi channel:
Are you sure there is no neighbours’ wifi interference on channel 11?
You can check it with
Android tool: Wifi Analyzer
Iphone tool: Network Analyzer Pro ($4,‐)

All other neighbours are running on channel 10 :slight_smile:
I will try to keep it on channel 10 and zigbee on 13

If your neighbours are on ch.10, i would advise to set wifi to ch.6 and keep zigbee at ch.13. That should be okay.

The ideal situation at your place would be wifi ch.1 and zigbee ch.17 or 18.

Note: if you set your wifi to an other channel, and neighbours wifi are set to automatic, it is possible their channel are gonna be changed.
So when you set your wifi to 6, run the analyze tool again after some time to check

Everytime Homey had an update I had the same thing. The blinds would not work anymore. I am not sure anymore but everytime Homey had a restart the same thing occured. For me the only quick sollution is to remove the blinds that don’t work anymore from the Homey app and add them again and adapt the few flows concerning the blinds that were removed and added. They keep working as long Homey has no update or restart. Perhaps the update and restart are the same problem as a restart occures on both of them. It is strange that only the Ikea blinds will suffer from this problem.

I don’t know if this is specifically a Homey problem. We have IKEA blinds connected to another Zigbee hub and half of them have stopped working altogether. They don’t even want to work with the IKEA buttons anymore. They work for 10 seconds after renegotiating. Then they just don’t react anymore.

Hey Willem, just disable auto updates. So you decide what and when you have to update, and you’re not ‘surprised’ with dead blinds. Version info can be found at developer.athom.com/firmware
App for auto notification of firmware and all apps: Homey Community Store

And, did you check your wifi / zigbee interference?

As best as we could.
We have had problems in the past, but since we exchange the WiFi accesspoints for Unify and added some dedicated Zigbee routers, we haven’t had any Zigbee problems anymore.
Besides, the blind next to it doesn’t have any problems. Neither do the 10 other Zigbee devices in the room.

Difficult to pinpoint, but I noticed you have 2 zigbee mesh networks.
How’s the channel separation?
To which zigbee mesh did you add the routers?

I have a hue bridge, how can I see the channel for that mesh?
It could be that it interferes with my homey zigbee channel

Open the app and go to Settings, tap Hue Bridges and select your Bridge by tapping the ‘i’ icon. Tap Zigbee channel change. Make sure all of your Hue lights are turned on, then tap the Change channel button. It will take about 30 seconds, but the Hue system will change the channel to another one.

Once done, your lights should all come back online. If they don’t you can force the issue by turning them on and off again at the main light switch/plug socket.


And yes, two hours ago Homey updated to 6.0.0 and now two of three Ikea blinds in the livingroom won’t work anymore as usual. We have five blinds, three in the livingroom and two in the bedroom. The three in de livingroom always give the problem, Homey is about two and a half meters away. The two in the bedroom hardly give problems, they are one floor up. I don’t understand why only a part of five won’t work.

Thanks Peter, but programming and reading programming is way out of my league.