Hue light to dim then off

Hi everyone,

I want my hue lights to dim after x minutes and then go off, i have created the below flow for this (this is just an example of my hal light). I am wondering, am i doing it the right way or is there a better way to do this? I am asking, because in general if works, but often the lights stay on, sometimes in full light, sometimes in dim mode, and sometimes it works and the lights go off. I am currently thinking it’s somewhere in the zigbee network where commands don’t get through to the light, but perhaps its in my flow.

Thanks for tips.

  1. Between the time blocks you miss 1 minute, between xx:00 and xx:01. It is better to link the time blocks with the yellow lines so they are mutually exclusive

  2. Activation of the scene may take time and then your card for Stop timer is delayed. Better stop the timers as soon as the motion starts

I use the zone active card, so i dont need timers.
My motion sensors are set to 1 minute. And the zone turns of after 2 minutes of no activity.

1 Like

Could you share your flow for my learning?
Would be much appreciated.

And my motion sensor is in the same “zone” with a short time before it activates again.

I use a light sensor to detect if the lights need to be on during the day.
And the time i used to make it less bright in the nights.

And one advantage is that when i need to repair my motion sensor the flow stays the same, because its not directly connected to that.

And a doorcontact in the same zone also triggers it.


In advanced flows there is a card for “Set the brightness for all lights in (Room) to” with the option to add a duration for this to take place over

Hi @Philip_Montgomery ,

Is that a seperate app? i don’t seem to have that card (or cannot find it). I saw it in the screenshot of @Maurits as well, but these are the options given to me:

I dont use it in my flow,
But when you have HUE for everything then you can select this one

In the Then column and then scroll to the HUE app at the bottom

Im feeling pretty dumb right now, but i see the following:

So i see the “zet de helderheid van alle lampen …” but without the “voor xxx” … am i looking wrong or?

Don’t feel dumb, I had to have it pointed out to me as it isn’t obvious, you have to be shown. Select the card, put it in your flow and then “right click” the card. In the drop down that appears you will see an option for duration

Ermm … :see_no_evil:I must be doing something wrong here…:sweat_smile:

What version of the Hue app are you running? I’m now wondering with this feature appeared with the test version

I have this version as well :sweat_smile:
But i still see you use the timers or is that for something else?

How odd … i just added this card to test the right button for options, thats why the timer is still in there.
Any suggestions what i could try to get the duration option?

Do you have actual hue bulbs or third party lights connected to hue. Maybe thats a thing?

I found the issue, i was taking a walk outside and the clear sky and sun helped to put some logic in my head :slight_smile: I had to reload the page, then “duration” showed up. I will try to change my flows using this card and see what happens. Thanks a lot for your (and Philip’s) help.

1 Like

Sounds like the old “did you try turning it off and on again”
Okay have fun building the flow!


@rizzah Hi, I do not wish to spoil the party, but if you are now going to build flows with Hue motion sensors and lights, then you should be aware that the Homey Hue app is not very quick in responding to motion due to a polling mechanism in the driver.

Last week I registered my Hue bridges as Homey Matter devices and the response times are super fast.

Homey is relatively new to Matter, but it works well with the stable firmware. And it is the future.

Dimming with delay is not yet available in cards for Hue as a Matter device, but I was using anyway another app for delayed dimming as I mostly work with lights combined in groups to avoid device dependent flows.

Here is an example of a Hue dim card (Matter):

Here is an example on dimming using transitions in Chronograph:

1 Like

Hi @Rrrr, thanks for your reply. I am aware, currently i use the local zigbee from the Homey to connect to the Hue sensors, that way it works quicker than connecting it through the app, like you mentioned.

I have tried Matter as well before, actually had to get a 3rd hue bridge for it to get working (otherwise to many lights on a bridge). Not sure if this issue is ‘fixed’ yet, and at first i was really pleased with it, eventhough some cards were not available. After a while i started getting issues with my Hue network, which i never experienced before (also not before using Homey, used Domoticz before). Things like, lights not going off after timer finished, or on at certain time, multiple lights that should dim at the same time (bathroom) but then only 2 or 3 went. None of these things were perminent, sometimes they went ok as they should. My first guess was that this was caused by the Matter, as it is still beta, but after reverting back to zigbee problems are still here. Hence i tried to see if there was something wrong with my flows.