Hue sensor flow in combination with hue light switch

Hi There,

I just switched from domoticz to homey and now i got stuck creating flows controlling hue motion sensor in combination with a hue light switch. Perhaps someone could guide me in the right direction.

Situation i pretty simple, i have a couple of hue lights in my bedroom, hue motion sensor and a light switch. I have created some different scenes it will load based on time and run a timer next to that (for example ,when i go pee in the night, only 1 light needs to be on for 1 minute, but during the busy morning routine it can stay on for longer). Next to that i have a Hue light switch, when i press that one i want everything to stay on for 60 minutes (regardless if motion is detected or not).

The ‘motion detected’ and ‘no motion detected’ flows are working as they should, my main problem is the light switch. When i press the button, it is seen and the flow i created for it runs. But, when ‘no motion detected’ kicks in, it will turn the lights off anyway. So, i am looking for a way the ‘light switch on’ flow overrules everything in the other flows.

My current flows are like this:

Motion detected:

No motion detected:

Light switch pressed:



In the No motion flow, you’ll need to add an AND card “timer slaapkamer60min is not running” right after the “No motion detected” trigger.

Then, the sensor can’t send a signal until the timer is finished after 60minutes

I also see you mix ‘timer’ and ‘stopwatch’. It’s not the same. So ‘start timerXYZ’ should be paused or stopped by ‘pause / stop timerXYZ’
Maybe it works (didn’t test), but it’s confusing in my eyes.

Just check the status of the button before the light is switched off. Or disable the flow with the motion sensor when the button is activated.

Why make you the Timers part so confusing.
Put the notification card after the “Zet Alle Lichten uit” card.
You can leave that card on that spot.

Or use one timer, which is set to the different values.
Then the problem is also solved, as pushing the button sets the timer to 60 minutes.

Thanks everyone, i might have overcomplicated the timer section, not sure why i thought the timers should have an unique value.
@Peter_Kawa Thanks, i added the ‘not running’ card.
@Rmb Changed everything to one timer, will test this today.
@Theo_de_Koning I could not follow/understand what you mean, perhaps you could elaborate for my learning and understanding. Much appreciated.