Homey Community Forum

Hue Motion sensor no continuous light

I have a Hue motion sensor placed in the hallway. My preferred setup would be:

  • when there’s motion turn on the light(s)
  • when there’s continuous motion, light(s) stays on
  • when there’s no motion anymore then turn off light(s) after x-seconds.

First I tried one flow, but that didn’t work well as that the light(s) will turn off even though there’s motion. So I now tried another setup with two flows. Also no luck.
Not sure if it’s also related to a delay (Hue motion sensor > Homey Pro > Hue spotlight). So I’m wondering if this can be fixed. The setup I now use is:

Flow 1
When … the motion alarm turned on
And … The time is between 20:30 and 06:30
Then… Turn on // 1 Hue spot light
Else… Turn all lights on in Hal // 3 Hue spot lights

Flow 2
When … the motion alarm turned off
Then… Turn all lgihts off in Hal after 1 min

Who can help me out with this? Thanks in advance!

Hi and welcome to the Homey community,

There are already multiple tutorials available.
From easy light control flows

up to advanced light control flows:

I guess you will find a solution for your requirements. If not, just ask.

2 Likes

If you’re wondering what is the cause and/or the difference with the examples in the tutorials:

When motion is no longer detected, the light is scheduled to go off. When new motion is detected this schedule is not canceled, so the lights will still go off. If you own a Homey pro, you can use a timer app instead of delays. Timers allow you to cancel the timer when motion reoccurs.

The other solution, which also works on Homey cloud, is to use zone activity. A motion sensor or door sensor in a zone will make a zone active. There is a card for when a zone becomes inactive that also can wait for a while, which does get cancelled if a zone becomes active again.

1 Like

Why do you engage Homey at all for that? I have 4 HUE motion sensors but I program them in the Hue app on my iPAD to do exactly what you describe.

Good question. It’s because I have 3 lights in my hallway and when at night I only want to make use of 1 light in stead of 3. Next to that, upstairs i have a same sensor setup but then with a LIFX bulb so homey should help me here too.

I have the same, at night I use all lights but only at 10% brightness. HUE let’s you set that. Yes, it’s not flexoble, mean I define the night 23:00-06:00 whereas with Homey you can use a button to set the house in “sleepmode”

The first option works for me (countdown), thanks for that!
The second one I actually tried first but could not get it to work (@Edwin_D). Yes the lights went on with activity but never did go off with the activity cards.

btw, didn’t try yet option 3.