How to see if Hue devices are controlled using Matter?

No, the app uses a local connection when running on Homey Pro.

Another upside of using Matter instead of the proprietary API to talk with the Hue bridge is that Homey’s implementation of the latter is based on polling, which means that it may take (up to) 2 seconds before Homey knows that a device state has changed. With Matter, state updates will be (nearly) realtime.

1 Like

With the newest Homey Pro Update to 10.1.4 it seems to work now. I get the camera screen to scan a barcode or click on “other options / without barcode” (I do not now the exact English translation as I am using Homey in German. That is great. :slight_smile:

Anyhow, I am still not able to add Matter devices from my bridge. I have a lot of Hue devices (44) and I remember reading about a bug that prevents adding a Hue bridge with a lot of devices. In the process Homey seemed to detect the Hue bridge (a dedicated Hue bridge screen with showed up), but then I got a timeout. The error message wasn’t really helpful.

So I tried a second bridge that I have, but is not in use. Reset, adding to the network, added two Hue play to it, checked that everything is working well in the Hue app, created the Matter code and tried to add this bridge to Homey using Matter. The same happened as before.

Did anybody successfully added a Hue bridge with so many devices, using an Android smartphone via Matter to Homey?

Short update on my Hue+Matter issues: With the newest firmware 10.2.1 I was able to add my Hue devices via Matter. A first round of testing went well. Responsiveness is much faster (which was expected due to the non-existing 2s polling delay). I’ve encountered that temperature readings from the motion sensors are missing the decimal places, but I will open a new topic for that.

1 Like

I did my migration today also on 10.2.1 and see the same for temperature but luminance is fine.
I will upgrade to Experimental updates and see if it is the same for v10.3.x

Question: did you re-install the Homey Hue app after migrating to Matter? That’s nice to know

No, I did not re-install the Hue app. In fact I did not touch the Hue app at all. I did removed all devices that I do not need to control through the Hue app anymore afterwards. I know that in the forum it is recommended to deinstall the Hue app, add then Hue devices through Matter, and then add devices through the Hue app if needed. I do miss some devices, maybe that is the reason why, but I do not know.

1 Like


I’m al bit new here. I will explain my situation and I hope somebody can help. I now have al my bulbs via the Philips Hue app connected via the Hue bridge. All is working very well now, but actualy I want it via Matter.

Can somebody explain me step by step what I have to do? And hopefully not to add all my bulbs again in all of my flows?

I appreciate your help.

If you are only using light bulbs I would recommend not to switch to Matter. There is, from my perspective, no real benefit. If you are using switches or motion sensors they will be more responsive with Matter.

You need to add the Hue bridge through the Homey app on your smartphone. The web app is not supported, yet. I am using the newest experimental firmware so you will only have the “Android” option to connect Matter devices. Then you need to choose the option “without QR code” and insert the pairing code you will get from the Hue app.

You need to add all your bulbs again in your flows as these are essentially new devices for Homey.

So, if you do not have a real use case, or like to play around with experimental features you do not need to add the Hue bridge as a Matter node.

1 Like

Here’s some steps: Add Philips Hue devices using Matter, not working - #74 by Rrrr
Going to matter won’t hurt but if you used hue devices in your flows then you’ll need to redo those.

Take a lot of screen shots or before you migrate, change the devices to virtual devices, groups, or advanced devices that will require less work afterwards. Or use zones instead of devices.

1 Like

No luck it’s the same

Athom support update on the lack of decimals for temperature in Hue motion devices connected through Matter:

Hello again :slightly_smiling_face:, I have taken a look too see if I can do anything about the temperature sensors lacking decimals. Sadly, Hue only seems to report rounded temperature readings through Matter. Nothing I can do here. If you want to get this fixed, you’ll have to ask Hue…

But if you re-install the (non Matter) official Phlips Hue app for Homey, then you (can selectively) increase the number of sensors but at lease those will show decimals in temperature.

Keep the Matter sensors for speedy motion response and use the non Matter ones for temperature readings if it is important to you to have decimals. :wink:

Hi everyone. I have the homey hue app and a lot of lights. Yesterday some of the lights and switches stopped working. Error message is “cannot find device undefined in hue v2 api”. Might that be due to some problems with matter? Has the hub switched some of them to use matter maybe? Is there a way to check if my hue hub uses matter to communicate with the lights?

I am on the version 6.1.8 of the homey hue app




If you didn’t explicitly set up Matter support on your Hue hub (and afterwards imported all your devices explicitly over Matter to Homey), you’re not using Matter.

Athom just broke the app, you have to wait for a new stable to be released or install the current test version which supposedly fixes it.

Thanks for the quick reply! Athom just emailed me actually. They released a new test version of the app which fixed my problem!

Just found this thread that shows the same error message I started to receive as well (Cannot find device41 In Hue V2 API). I actually emailed Homey support and they just said I should reinstall the app. They didn’t even mention there is a new version that will fix this. Which is odd. You would think that support would know that. But good that the community forum is here.

Solved with a firmware update on Hue

Thanks for the info. I can confirm that! :slight_smile: