How to remove a "unknown node"

as the title already explains. I have a unknown node in my network and I would like to remove it from the network. Is there a way to do this?

Resetting the chip and rebooting homey ( and even running an update) doesn’t fix it.

Sure, goto
goto the end of the line of the Unknown Node, click on the 3 dots, the rest you can imagine:

some times you have to refresh this page to see the results.

there is no remove button… thats why I ask.

indeed some nodes have a remove button and some do not :frowning: here the same problem with an unknown node without remove button

I had a Fibaro switch that was broken but couldn’t be removed for months as it clearly won’t respond to anything (it’s no longer there) . The X in the top right corner in Homey to remove the device should have timed out and remove unknown/unresponsive devices from Z-Wave automatically but it didn’t. Remove button in tools section is not visible and I didn’t want to reset the entire Z-Wave network as I’d lose all my devices.
The latest revision Homey SW has brought the remove solution back to life.
Is this similar to what you’re trying to achieve?

1 Like

And via the page: Settings - Z-Wave - Remove a device ?

For that to work you need the device. But as I already said its a device that I don’t know what it is. So I can’t remove it

Same for me in V2.0 2 Unknown nodes without possibility to remove.

Me too. Some unknown nodes. No remove Button. Frustrating!

Same problem here…hope it is possible after the next update?

Same here. Sucks.

Same problem here. Using v2.0.2. Athom, when will this be resolved?

Same here. Tried to add Fibaro Button several times.
System did not reacted any way pushing button six time, and told, no devices found.
But if I looked in developer view, I saw there “unknown” node for every attempt to add device.
Once Homey recognized Button add request, but could not able to finish process and aborted it.
Now I have lot of unknown nodes and no possibility to add button anymore, because system tells me, allready_added

@Tundel During remove/exclude and add/exclude, always keep Homey and Device within a short distance (less then 50 centimeters) this prevents from " no devices found “. When the message “already added” apears, the device can be removed with the general " remove any device” button.

but what happens if you press the remove any device and you don’t have the device that you want to remove? Because I don’t know what node 14 is. That is the problem. Not that I don’t know how to remove it. I just don’t know which device this ‘14’ is and therefore can’t put anything in pairing mode to remove it.

1 Like

@Jeroen_Somhorst Was refering to @Tundel [quote=“JPe4619, post:14, topic:4539”]
When the message “already added” apears, the device can be removed with the general " remove any device” button.
Sorry, don’t have an answer to your question.

I had the same problem. I made several flows with the unknown node. With these flows I hoped to solve the unknown issue. Without result. I tried to look where the zwave signal did go to along(developers page). I hoped to track the last node i do know which extended the zwave signal to my unknown node. That way I knew a little bit were to look for the unknown node. This also didn’t work because all the other nodes were also unknown, except for homey. Luckily i wadcabke to remove the unknown node through the developers site. Afterwards it occured to me that I had removed(just removed it from the wall plug)this unkown node a while ago and apparently had added it again after a while in homey with another name. I did not know this was/ is possible. I hope this will ring a bell for you.

I just got word from Athom support. It is currently impossible to remove such nodes from the zwave. And according to support they don’t do any harm and don’t affect the network. They will solve it in a future update. But that again :soon:

1 Like

Hi again, yes it works, but i had to heal it first before remove option apperaed

1 Like

As of now, i apparently can remove them again. Since a few weeks there is a “test” function per device on the developer page (press on the three dots) . If you press “test” with an unknown node it becomes “unreachable” and then the “remove” option is no longer grayed out. I removed all 3 unknown nodes i had.

Not sure if they will be back after a reboot, will try that later and report here.

-Report- They didn’t come back after reboot.