How to remove a dead z-wave node

I’ve been searching the community and looked around in homey but I am not able to find a way to forcefully remove a dead z-wave node. I’m on Homey 2.0.
Any ideas would be greatful!


Plus 1 , i have multiple dead nodes ( old devices) and still present in homey.

Go to device, long press to open. Goto settings, top right, select remove device and wait… Normally you would press a button on the device but you can wait it out and the device is removed.


my understanding is that removing it via the devices page only removes it from the overview, not the core system. i have a faulty node that i added and remove a few times. even though i have removed all of them in the devices page, my alexa skill can still see all of them as offline devices! was hoping someone can help with this.

Take a look: > Tools > Z-Wave. There was an Option to delete e.g. Unknown Devices. Don’t know if this Option is avaible anymore.

1 Like

Alas it isn’t. It was there for use with “unknown nodes” but it disappeared.
It is now only there for known nodes that don’t respond.

Sounds like it’s a bug that should be reported. Removing it this way results in a confirmation message that it’s in fact removed. If there are still traces of it it’s clearly something wrong.

I also have two unknown nodes, since a long time already.
No way to remove them, but they don’t do any harm either.

This is a very old still active bug. Should be fixed in 2.x

I don’t think 2.0 can fix this just like that.
As far as I understand it, it’s a node that is defined on the z-wave controller, but unknown to Homey.
So it should actively be removed from the controller, it won’t just disappear with a software update.
(disclaimer again: if I understood it correctly :smile: )

One of the 1.5 firmware’s had the possibility to do exactly that. On the “menu” part behind the devices there was a “remove” option with all the devices, even the “unknown” ones. Sometimes it worked immediately, sometimes after a few tries and reboots. There was a topic about that if i recall correctly.

I’m running 2.0 and can’t find any way to remove the node.
Guess it’s something I have to live with, or reset the entire z-wave network…
Thanks for all ideas.

Have you tryed this written above in this Post:

It isn’t:

Just tested.
Open app , goto devices ,long press on dead node, settings wheel , remove device, wait for a very long time ( some time out ) message will appear with device is removed.
Tested it on multiple dead nodes from different vendors

Cheers Marco

there are no dead nodes in the devices list of the app… i only can see the dead nodes in the developer.athom site
and there i cant delete them… like @PetervdK shown

1 Like

That worked for me.
Just had to be really patient.
Thanks a lot!

Okey story continues

Seems like their is a difference between dead and unknown node.

Yesterday I tested in the app with dead nodes removing and this is working like a charm.

Today in logged in the backend via and see a lot of unknown devices. Those can’t be removed , there is no remove button behind the dotted lines only heal and send on or off state.

Just my 2 cents


Same here.

1 Like