Homey zeer instabiel op de late avond

Sinds een aantal dagen ervaar ik toch wel wat vervelende maar vooral irritante problemen met Homey.
Als ik mijn flow laat draaien dat ik naar bed ga wordt alles instabiel. Sensoren werken niet meer of met enorme vertraging, licht gaat aan/uit. Draadloze schakelaars reageren ook of niet of met enorme vertraging.
Als ik bij inzichten kijk zie ik enorme pieken in cpu en geheugen van Homey rond de tijd dat de flow heeft gedraaid.
Maar ook midden in de nacht zijn er hoge pieken te zien die ik niet kan plaatsen want dan gebeurd er vrij weinig.

De flow “Naar bed” draai ik al maanden zonder problemen. Wel heb ik wat virtual devices aangemaakt maar of dat nu het probleem is betwijfel ik maar sluit natuurlijk niets uit.

Zijn ere meerdere Homey gebruikers die dit de laatste tijd ervaren of ben ik de enige?
Wellicht kan iemand me op het juiste spoor zetten om de boosdoener(s) te vinden?

Ik heb vanmiddag de flow “Naar bed” op de dag uitgevoerd en daarna werkte alles nog gewoon prima dus zou ik denken dat die flow niet de boosdoener is.

Ik heb vanmiddag ook een ptp uitgevoerd en weer een andere power supply erop gezet maar dat heeft dus niet geholpen.

Omdat mijn gezinsleden er ook niet blij van worden en ik er zelf nog niet achter ben hoop ik hier wat hulp te krijgen.

Alvast bedankt voor het meedenken.

Naar bed flow

Gebruiksgrafieken van Homey.

Virtual Devices

Eerst zou ik kijken of je in insight de geheugenpieken op een bepaalde app kunt terugvoeren. Of is dat echt alleen systeem? Dat zegt ook niet alles: het systeem gebruikt ook geheugen t.b.v. andere apps. Hetzelfde natuurlijk ook kijken bij de CPU voor elke app, mogelijk misdraagt zich een app die geupdate of toegevoegd is?

Verder zou ik zou denken aan een flow die veel vaker runt dan je verwacht. In de webversie is bij elke flow in een tooltip bij de flow hoe vaak deze is uitgevoerd. Dat kan helpen als je een flow verdenkt van te vaak uitgevoerd te worden.

Omdat het ‘s avonds ‘s nachts is zou ik dan denken aan flows zoals:
als de helderheid verandert en de helderheid is kleiner dan … doe iets.
Zo’n flow triggert namelijk elke keer dat de helderheid verandert en de helderheid laag is (in tegenstelling tot: als de helderheid minder wordt dan … doe iets - die treedt maar een keer op als het van boven naar onder de ingestelde helderheid gaat).

Ook ander flows op basis van veranderende waarden of “elke … seconde” kunnen dit soort gedrag veroorzaken als de acties zwaar werk zijn. Denk bevoorbeeld aan tests op energiewaarden van stopcontacten of zo, en dan natuurijk ook weer wat ‘s nachts vaker gebeurt dan overdag.

Goeiedag, wat veel actie kaartjes :flushed: Een tip, zet er meer vertragingen tussen, zodat er hooguit 4 of 5 acties tegelijk worden gestart. Er gaan wel signalen verloren als Homey te veel tegelijk moet doen.
De actie kaartjes worden nl. niet op volgorde gestart maar tegelijk… (helaas)

Ik dacht zelf inderdaad aan de virtual devices app omdat ik daar de laatste tijd wat van heb aangemaakt met diverse opdrachten.
Ik zal een naar de frequenty van deze flows kijken en aanpassen waar het kan.

Verder zal ik kijken naar flows die (te) vaak zouden draaien.

Bedankt.

Het zijn inderdaad veel kaartjes maar heeft altijd gewoon prima gewerkt zo. Ik zal er wat vertragingen tussen zetten en kijken of dat helpt.

Ik had zojuist ook dat homey ineens weer op niets reageerde. Dit gebeurde gister ook al uit het niets.

Gister sprong ineens een lamp aan en toen zei homey dat de Ikea app dit deed. (Zonder flow of iets dergelijks)

Na een herstart is alles dan weer op de rit

Power supply heb je al geprobeerd dus dat valt af, maar weet je of de stroom zelf wel betrouwbaar is? Na een korte stroomonderbreking kan een Lamp aan gaan. Als Homey dat merkt dan “zet de app hem aan” volgens de logs. Of is de lamp via Light link o.i.d. ook aan andere bediening gekoppeld? Dat geeft een vergelijkbaar effect.

Gisteren heb ik wat vertragingen toegepast op mijn “Naar bed” flow en wat virtual devices aangepast maar het heeft helaas niet geholpen.
Nadat ik de flow draaide liep alles weer in de soep en reageerde vrijwel niets op sensoren en draadloze schakelaars.
Voordat ik de flow draaide heb ik een test ronde gemaakt door het huis en ging met alle sensoren gewoon overal het licht aan. Na de flow dus niet meer.
Ik heb de Homey opnieuw op moeten starten om alles weer werkend te krijgen.

Helaas was het ook vanmorgen niet best met alle sensoren. Wederom (zonder dat de Naar bed flow was gedraaid) werkte alle sensoren en draadloze schakelaars niet. Pas nadat ik wederom een ptp van 15 minuten had gedaan en de “oude” stekker van een iPad er weer op had gezet werkte alles weer.

Ik ben nu bezig om al mijn vurtual devices ten behoeve van mijn verlichting om te zetten naar Groups apparaten. Als ik vanavond de flow draai zullen we zien of het heeft geholpen of niet.

Als ik naar de grafieken kijk vermoed ik toch dat de virtual devices het probleem veroorzaakte maar ik ben geen grafiek expert.



De virtuele devices grafiek ziet er prima uit.
De laatste 2, geheugen en gemiddelde belasting zijn wel apart.
Kun je een app vinden met een soortgelijke grafiek? Voor het geval het in een app zou kunnen zitten.
Ter vergelijk mijn Homey’s geheugen en gemiddelde belasting

Aangezien een flow de ellende start: zit er mogelijk een lus in je flows waardoor de acties elkaar blijven aanroepen? Je zou eens kunnen kijken met papertails. Die kan volgens mij een logregel aanelke flow toevoegen. mogelijk veroorzaakt de bed flow een flow-lawine die je dan terug zou moeten kunnen zien.

Het lijkt de simple log app te zijn. Die toont grote overeenkomsten.

Papertrails had ik al verwijderd. Lijkt dat ik dat met Simple log ook maar ga doen.

Probleem wordt ook bij mij herkend, tot enkele dagen geleden geen problemen, nu zet Homey enkele stroomschakelaars steeds weer uit. Iets wat in de update 7.2.0 is ontstaan?

Ik heb toch niet het idee dat het de bewuste “Naar bed” flow is die de boel in de war brengt want het was gisteren voordat ik naar mijn werk ging prima werkend maar hoorde van mijn gezinsleden dat er later op de dag weer niet veel werkte qua sensoren en verlichting.
Dat was vanmorgen nog steeds zo en heb net voordat ik weer ben vertrokken Homey heel even stroomloos gzet en weer aan en nu lijkt het wel weer te werken. Voor hoe lang deze keer gaan we afwachten.
Ik heb ook wel het idee dat er met 7.2 iets niet goed zit.

Zigbee via de officiele Hue app in Homey werkt wel goed maar alle andere varianten van Zigbee zonder bridge, Aqara etc werken dus regelmatig niet goed. De sensoren werken mogelijk wel gewoon alleen omdat de lampen niet werken lijkt het of die ook niets doen.

Vanmiddag thuis maar weer eens verder kijken hoe het gaat.

Hier ook vrij instabiel met 7.2 hiervoor al een tijdje geen last gehad

Gisterenavond was het weer mis met alles wat zigbee was. Voordat ik naar bed ging werkte de verlichting aan en uit prima. Na de bewuste “Naar bed” flow was het een drama. Vertraging van wel 10 minuten voordat iets reageerde of het ging gewoon helemaal niet uit.
Op een gegeven moment heb ik zelfs lampen eruit moeten halen om het licht uit te krijgen omdat het midden in de nacht bijna overal spontaan aan ging.
Op dit moment wordt ik niet heel blij van Homey en zijn Zigbee want dat is het enige wat problemen geeft. Verder werkt alles gewoon prima.

Mijn huidige setup die dus tot een paar dagen geleden gewoon prima werkte bestaat uit behoorlijk wat Zigbee verlichting waarvan de gekleurde lampen van Philips Hue zijn onder gebracht in de Hue bridge en zo is gekoppeld aan Homey. Zigbee kanaal is 15.

De niet gekeurde lampen waarvan er veel van Philips Hue zijn heb ik direct gekoppeld in Homey via de Hue zonder bridge app. Zigbee draait op kanaal 11 in Homey.

Mijn 4 access points in huis draaien op kanaal 4, 6, 11 en 12 en dat zou volgens de WiFi ZigBee Interference Checker kleine problemen kunnen opleveren op 4 en 6. Deze heb ik inmiddels nu aangepast naar 8 en 10 en zou het geen problemen meer mogen geven.

  1. Vraag hierover is kan zowel Homey Zigbee als de Hue Zigbee op het zelfde kanaal draaien of is het beter om deze apart van elkaar te laten draaien zoals nu gaat met 11 en 15?

  2. Is het zinvol om nog wat Philips Hue lampen aan de Hue Bridge te koppelen en niet meer direct aan Homey Hue zonder bridge of heeft dit niets met het huidige probleem te maken.

  3. Zoek ik naar een speld in de bekende hooiberg en is dit gewoon een Homey Zibee probleem onder versie 7.2?

Verder ga ik nog wel mijn naar bed flow maar eens aanpassen om te zien of daar toch wat winst mee te behalen valt.

In mijn grafieklijn zie ik nu geen enkele app die een soortgelijke lijn heeft als Homey aangeeft in zowel cpu als geheugen.


Edit: Wat er ook nog gebeurde gisteren rond 21:50 uur voordat de flow naar bed werd geactiveerd was dat ik een melding kreeg “Zigbee is hersteld …”

Ook zijn er gewoon spontaan meerdere lampen verdwenen uit mijn setup zonder dat ik daar zelf iets mee heb gdaan.

Heel vreemd allemaal.

Ik heb zelf wel eens het idee gehad dat Flowchecker bij zijn automatische controles veel resources gebruikt. Ik heb zelf auto-ckeck uitgezet en vervangen door een nachtelijke controle en een flow voor een handmatige check. Al eens geprobeerd Flowchecker uit te zetten?

Dat zou zomaar weleens kunnen ja. Deze heb ik wel recent geïnstalleerd.
Ga ik uitzetten en kijken of het helpt.

Bedankt.

Ik denk dat ik nu alles wel heb geprobeerd wat hier is aangegeven en wat ik zelf kon bedenken maar het wordt eigenlijk alleen maar erger.
Erger werd ergernis en daarom heb ik besloten om all Hue lampen die direct waren gekoppeld aan Homey Zigbee te verwijderen en te koppelen aan mijn Hue bridge en zo weer te importeren in Homey. Dat werkt gewoon wel goed.

Blijven er nog steeds heel veel andere apparaten en merken over over die ik niet in mijn Hue bridge wil omdat deze al met behoorlijk wat apparaten is gevuld nu.

Omdat er dus echt helemaal niets meer werkt via Homey Zigbee na meerdere ptp’s van tussen de 30 en 60 minuten heb ik besloten het Zigbee netwerk te resetten.
Ik wil dus nu de overige Zigbee devices zoals Innr lampen, Robb smart devices, Aqara devices etc opnieuw gaan koppelen aan Homey Zigbee.
Daar stuit ik nu al gelijk op het eerste probleem want wat ik ook probeer de devices laten zich niet meer installeren. De apparaten worden wel gevonden en Homey geeft aan te installeren maar op een gegeven moment krijg ik de melding dat het te lang duurt.

Ik heb met een verlengsnoer de Homey naast de te installeren apparaten gezet maar zonder succes. Hue bridge uitgezet tijdens het koppelen hielp ook niet.
Er is mijns inziens iets gruwelijk mis met (mijn) Homey Zigbee want verder werkt alles wel gewoon goed.

Ik heb mijn Hue Bridge en Homey op zigbee kanaal 15 gezet. Dit omdat de Hue Bridge daar al op stond en prima werkte en Homey stond op 11 en deed niets meer. Ik heb hier gelezen dat dit het beste is om te doen.

Voor nu weet ik het ff niet meer dus als iemand nog een ingeving heeft wat te doen hoor ik dat graag.

Hi Alex,

Ik zou je het advies willen geven om niet direct alles wat hier op dit forum over te gebruiken wifi en zigbee kanalen gepost wordt als ‘de’ waarheid aan te nemen, wellicht inclusief mijn post hier.
Dat gezegd hebbende, als je wat verder kijkt op de site van MetaGeek zal je zien dat het algemene advies is om juist kanalen van elke en ook binnen elke technologie (wifi/zigbee) zo veel mogelijk te scheiden.

Bij wifi gebruik je (in Europa) idealiter alleen kanalen 1,6 en 11 en probeer je de zigbee kanalen ‘in de dalen’ van de wifi grafiek te zetten, idealiter 15, 20 of indien beschikbaar op de zigbee apparatuur 25 of 26.
Helaas zal je mogelijk ook te maken hebben met invloeden van buitenaf; wifi signalen van bijvoorbeeld je buren.

Deze afbeelding (van MetaGeek) geeft een aardige indicatie, maar is slechts indicatief (Er wordt bijvoorbeeld volledig voorbij gegaan aan signaalsterkte)

Mijn ervaring is dat het voor je Wifi desastreuzer is om daarin kanaal overlap te hebben dan kanaal overlap met Zigbee.

Overigens zal dit je helaas waarschijnlijk niet bij je problemen met betrekking tot de instabiliteit op de late avond helpen maar wilde het je toch even meegeven.

Hoi Danee, Ik denk dat wij jaren terug ook al eens op een MCE forum zaten samen. :wink:

Ik ben net als met vele andere automatisering producten slechts een enthousiaste gebruiker die als hij iets niet weet of ergens niet uitkomt een forum bezoekt en daar probeert verder te komen. Ook in dit geval ben ik op zoek gegaan naar een oplossing voor mijn huidige probleem met Homey Zigbee.
Ik kwam dat topic tegen en dacht, ik ga dat gewoon proberen maar nu geef jij dus eigenlijk aan dat het niet de beste keuze is. Wat je zegt is dat net als bij verschillende access points voor wifi je verschillende kanalen moet gebruiken dat dus ook moet doen bij meerdere zigbee hubs of bridges.
Dan ga ik dat weer terugzetten want zo heeft het ook altijd gewoon goed gewerkt met Homey op 11 en Hue bridge op 15.

Of dit inderdaad mijn huidige probleem gaat oplossen betwijfel ik want de devices die eerder van de week gewoon spontaan verdwenen en na mijn zigbee reset van eerder vandaag helemaal weg zijn krijg ik momenteel met geen mogelijkheid weer gekoppeld.

Dus als jij of iemand anders hier nog een goed idee voor heeft dan hou ik me aanbevolen.
Ik begrijp gewoon niet zo goed waarom het met de Hue bridge via Homey wel goed gaat en direct via Homey gekoppelde apparaten niet. Tot een dag of 4 geleden geen enkel probleem.

Kan dit ook duiden op een defect? Dat zou voor de tweede keer in 1 jaar tijd zijn dan. :cry:

1 Like