Homey Z-wave communication very slow

I have a Homey Pro 2023, and I feel I’m just getting started adding devices to it, and it’s already getting extremely slow.

I have approximately 35 z-wave devices. Most are from HeatIt and are thermostats, dimmers, relays and some battery-powered switches. I have a few zigbee devices, but haven’t really started adding them yet, as I want z-wave to be stable first.

I have several direct associations set up, which seems to work great. Usually less than 1 second from button press until the associated nodes will activate.

If I activate a device from the Homey app, it’s usually instant.

The problem is that I have some buttons that activate flows. So f.ex. I have one set up to turn all lights off. The first couple of lights will go off almost immediately after triggering, but then it can take up to a minute for the last light to turn off, and it seems to get slower and slower.

I also have a HeatIt z-push button that activates a flow for a roller curtain (433MHz).

  • If I were to use the (“Brel remote”) device directly in Homey - it’s pretty much instant reaction.
  • If I start the flow manually, it’s usually half a second delay or so.
  • If I use the z-push button, it takes 8-10 seconds before the flow is started.

I have tested adding a simple push notification for another button, and it does take 5-10 seconds before I get it, where I’m pretty sure most of the latency is from the button it self.

So I find it strange that direct association works so quickly, but via Homey the Z-wave network seems to be very slow. I’m currently using insecure z-wave as well to make sure the traffic was as little as possible.

What could be wrong? Could really a network of only 35 devices create congestion? Are they sending statuses to often etc? It seems like it’s set to push information every 60 or 90 seconds, so it’s not really that often.

It shouldn’t, but check if zwave mesh devices might be too far apart from eachother, or if they’re not operating at the edges of the range.
In theory 231 devices must be possible

Search Homey & forum for “chatty devices”
Maybe it’s related.

Which firmware is running? Athom made some fixes (or tried) a while ago.

Thanks for replying!
Regarding the mesh, the slowest of the switches is actually connecting directly to Homey. And there are pretty much 2-3 Z-wave devices on 230V in every room, so it should be a pretty decent coverage.

I did check developer tools and found that some devices have a lot of lost packages, like 30-40%! So I need to check up on that.

I’ve also seen that some devices take strange routes, like two floors down, then one up, one down again etc, even though it is in the same room as the first hop. Forcing it to create a new route made it skip a couple of hops, and reduced lost packages to only 5%.

I (hopefully not against forum rules) cross-posted to the HeatIt thread, as I’m mostly using devices from them, if it in fact could be very chatty devices that spams the network.

I’m using the latest stable version, 10.2.0.

I’ll check the chatty thread you linked.

Edit: I can see that there are settings for power meter updates in seconds, and a threshold that can be set. I wonder if some of these could be the culprit, but I’ll check dev tools first.

This device is a thermostat two floors under the Homey, and there are multiple hops possible, but still it connects directly, and seems to have a high Tx Error rate. This thermostat is however not currently in active use, as the floor heating is defective, so it’s basically a thermometer only.

I did some more tests.

First, I set updates to 900 seconds (15 minutes) for all devices. Thermostats were set at 90 for metering and 300 for temperature.

They are less chatty, but I’ll have to see what it does for the system over time. So far, I see no difference.

But I did have some other strange discovery - the Z-push button that took 8 seconds to activate a flow, it is still slow, but the right button (it’s a three button panel) sent me a push within 1 second!

So for the heck of it, I set the flow to react on the right button instead of the middle, still on the same actual device, and it now activates within 1 second…

So again, very confused, I move it back to the middle button - back to 8 seconds again…

I’ll check with HeatIt, because this just doesn’t seem right…

1 Like

I think it’s cool when you just mention it clearly in your 1st post, while this seriously could be a Heatit issue as well.

1 Like

So I’ve done some more testing, and I don’t really think the Z-wave network seems any faster. But if it was sending unnecessarily many messages earlier, it’s probably fine to reduce it anyways.

I have a switch by the main entrance where I can start a Homey Flow; “Turn off all lights”.
This IIRC did work faster before, but now the first couple of lights will turn off after a second, while the last can take everything from 10 seconds and up to a minute.

I tried separating the floors in the flow, so it turns off 1st floor, waits a couple of seconds and then turns of all lights in the 2nd floor, but it doesn’t seem to make a difference.

Is this to be expected? It’s probably 25+ devices I’m asking it to turn off.

So it seems to be a lot less chatty, and much less transmission errors. Just a couple of devices, one with 30%, but otherwise very low compared to before.

I still feel it’s a bit slow to f.ex. turn off all lights though, but it seems to work stable.