Homey rainbow

Hi all,

Situation: my homey was working fine, I had to restarted it yesterday and suddenly rainbow ring and waited longer 20 min and still didn’t come online. I have put it in recovery mode and tried to connect to my WiFi 2.4, blue ring and after a while I get message WiFi is not connected.

Any help will be appreciated. Thanks

Best. to contact support:


In the meantime, did you replace the power supply (with a 5V/2A+ Samsung or Apple f.i.) and usb cable already?
The original supply is known for possible degrading in performance over time.

HI, i did,
right now im still using the original one, rainbow ring is gone but Homey keep losing wifi connection. or at least it shows Homey pro is offline and when it comes back, one error message: the app Loqed has stopped working. The developer has been notified.

If you’re still using the original power supply: replace it.

Hmmm, I don’t get why you use the original power unit again?

This can be caused by an app, and Loqed seems as suspect here.

Check insights memory usage for every app, to find out if it (sometimes/often) uses over say 50MB (enable …More>Experiments>Power User to view those).
This behaviour causes the wifi to go down somehow.

Homey kills apps which use over 80MB, but that’s too late for the ‘chocking’ of the wifi connection.

I missed that you already suggested replacing it :sweat_smile:

Wouldn’t it be more likely that it’s the power supply? This is a classic symptom of one failing.

i have used another power unit. sorry i forgot to mention it in my previous post. same result, so the power unit is not the issue. thats why i went back the original one.

1 Like

Ha yeah, but Tarecco wrote he used the original one again, so your point was :+1:

Well both I think. I can reproduce it; For instance, it kills my wifi by running lots of homeyscripts on purpose. When I check insights later on, the memory usage went over 50 - 60MB.
It happened also when Papertrails got lost in “Homey memoryland”.