Homey Pro USB Tool on PC requires .exe?

Hi yall,

I was going to use the “Homey Pro USB Tool” to update the firmware since Zigbee is stuck at “Starting” but the article asks me to download and install “Homey Pro USB Driver v1.0.0.exe”. I tried to dl the file and it was flagged as potentially malicious by Microsoft Defender SmartScreen.


I downloaded the file anyway and tried to install and UAC prompts me as to be expected. The file however is not signed by a trusted publisher.


Anyone know why is the file flagged by Microsoft Defender SmartScreen as potentially malicious?

And how come the file is not signed by a trusted publisher?

Feels a bit iffy to install the file…


Moderation: Replaced Link with original direct link to Support article. (by @Dijker)

Probably because it’s not signed by a trusted publisher?

Athom aren’t really a Windows company (macOS and Linux don’t require additional drivers for the USB tool to work), my guess is that this driver is best-effort only.

They should be aware of this, but nonetheless I think it’s a good idea to inform Athom about this, because it is quite silly / unprofessional, right? Despite their limited Microsoft knowledge they should (try to) fix this imho.


Thanks for your answers guys.

I asked a support person this in a support case and the answer I got didn’t adress my questions at all, which is why I turned to the community.

I don’t think it should matter what company you are. It should be no sweat to make sure your official .exe that you suggest users to download in order to flash the fw is trusted by browsers regardless of the OS.

Similar it should not be hard to sign the file for the same reasons.

Since I am a new user I don’t know if any official Athom mods frequent the forum but it would be interesting to see their view on this is.