Updating frameware to 10.0.0-rc.64 to 10.0.6

I just bought a Homey pro 2023, and you are completely new to the Homey world
It has been set up as it should and there were no problems.
But. when I look under “update” I can see that there is a framiware update. my homy pro is running right now ver. 10.0.0-rc.64 and the new firmware er ver. 10.0.6. I have now downloaded and installed this update several times without any problems, except that every time my Homry pro has restarted after the update, it shows that the firmware is stable. 10.0.0-rc.64 is on the device, and that there is an update to the ver. 10.0.6 must be downloaded and installed.
what do i do

Super day to all of you

That is strange indeed…
Did you try to update your Homey by connecting it to a pc?

Tip: use a USB-A to USB-C cable, not the one provided with your Homey.

EDIT: I see another post with the exact same problem and versions as yours. The above solved it for this user:

Yes. Updating with the USB tool fixed that problem for me. Don’t forget to make a backup before you start, so you can restore all your setting afterwards.

Making a backup before updating is always a good idea!
But you shouldn’t have to restore it, since updating shouldn’t reset your Homey and therefor keep all the data.

Connecting my Homey to my PC with a USB-C to USB-C cable and updating that way solved the problems. It was not necessary to use the backup I of course made first.
thanks for the help