V1.x to V3 firmware update kills Homey?


I had a v1.x on my Homey. I was pretty happy with my setup but lately it started to misbehave. So I wanted to reset my Homey and upgrade it to a stable V2 (if I am already going through the pain of complete reset). So I put Homey up side down » countdown » setup.athom.com » delete existing settings. Nothing new till this point but here came the surprise: without giving any option it said looking for firmware update and than downloading v3.0.0-rc.18. Whaaat? Than it started to update the firmware. It is one thing to do an upgrade without consent but upgrade to an experimental version? Anyway I did not have a choice at this point, did not want to brick it so I did not unplug it. The upgrade went for hours. Then restarted and the LED went to Red. I left it in that state for a while then unplugged it. At restart Homey went into the setup.athom.com mode again. The only difference that it says it already has the latest firmware. From this point I got into a loop. Setup » restart » goes to RED » unplug and goes back to setup » setup » automatic restart » goes to infinite green spinnig » unplug and it goes back to setup again. It is Groundhog day.

I tried the setup on desktop and on the app as well.

Any idea? Anyone had this or similar issue before?

My best guess is that not the upgrade from v1 to v3 is the issue but that your Homey was misbehaving already.

I hope you already contacted Athom Support but the upgrade issue is very strange and for what I know you are the first who reported this. Also as rc.18 is not available outside Athom yet, rc 17 is still the latest in public and selected channels.

By misbehaving I don`t refer to software issues (or consequently to memory or processor errors). The 433Mhz frequency band tend to shift with temperature change and also over time. My LightwaveRF and Somfy devices started skip signals. Nothing new, happened before and a resets on both sides solved the issue. Nothing else was affected.
I know that RC17 the latest official release and my memory might be wrong. I wish if I could double check.

I am sure others had loop problems before. Any solutions?

In that case I guess you did not choose the factory reset (hoose deleting all data ) in step 3. Maybe you where in Experimental before and thus updated to RC17 when choosing to update.

Only way out if factory reset doesn’t work is contacting support. There are no other tools public available to un-brick.

Yes that is how I reseted homey on the first place. I am very much familiar with the process. I had a fairly reliable system so my firmware and app update was disabled. I was on a stable version. Also the (up-side-down) factory reset only works once the system boot finished. It does not work in the setup stage or after (as the system boot never finishes).

After many many loops, eventually got it to work with firmware version 2.5.2.

1 Like

How did you get it back to v2.x? I am in the same boat here. Got welcomed by a red light of death last week on a morning when I got down stairs and saw Homey… ever since attempting to recover it failed. Athom support is no help at all, they just want you to send in Homey to ‘fix’ it. But, imho this a. seems to be something related more to something happend on their infra side and b. my homey worked and only performed like 4 to 5 flow controls which haven’t changed in more than a year. People stating it migh be power adapter failure, but I disagree as the behavior should then be more different and random, which now in recovery it’s not. It shows red light of death at exact same moments whole time.

Athom is really not responding still and more people are reporting issues.

Not sure what you’re waiting for if a) Athom has suggested to send back your Homey but you won’t and b) others have suggested swapping out the power supply but you won’t.

If you read in the other thread: I did swap out the PSU already. No effect.

I think the offer being suggested by Athom is pretty fair.

This is also hilarious, I am trying to recover Homey, and you find this page:

" Purple - Homey is updating itself at the moment, do not turn off the power.
Or Homey has been powered on upside down (turn it off and turn it on when upright)"

So… what is it now? I did recovery, it ended up in not recoverying and I restart it, holding it upside down to get in recovery mode but it shows a purple ring.
Is it updating or just saying it started upside down?

It just is not thought through… it needs to be more distinctive.

Purple ring is the same, but the animation used is different, for the recovery mode (though should be named Athom Only recovery mode) it is pulsating (breathing) and going round, where updating it is just percentual (so 1 LED = <8%, 2 LED = 8-16%) going around.

resetting for customers can only be done 10-20 seconds after power has been applied, to NOT end up in the Athom Only recovery mode, but in the normal resetting mode.

1 Like